0

I have a 100% CPU load caused by www-data various users.I traced the PID and the result is a repeating of this 3 lines of code :

lock_gettime(CLOCK_MONOTONIC, {41414, 205227694}) = 0
rt_sigaction(SIGPIPE, {SIG_IGN, [], SA_RESTORER, 0x7f439a8c2390}, NULL, 8) = 0
poll([{fd=16, events=POLLIN|POLLPRI|POLLRDNORM|POLLRDBAND}], 1, 0) = 0 (Timeout)

I also run a strace -fcp on the PID and got this :

root@......:~# strace -fcp 26330
strace: Process 26330 attached

^Cstrace: Process 26330 detached
% time     seconds  usecs/call     calls    errors syscall
------ ----------- ----------- --------- --------- ----------------
 65.17    0.092603           1     72271           clock_gettime
 33.14    0.047089           1     70464           rt_sigaction
  1.69    0.002397           0     23488           poll
------ ----------- ----------- --------- --------- ----------------
100.00    0.142089                166223           total

I looked around and gathered all this info so far but I have no clue how to proceed from Here. The website is on a VPS using PHP 7.1. Any adice how to stop to fix this issue ? Thank you

  • 1
    Problem solved - a nameserver (from 4 nameservers ) was pointing in the wrong direction . As soon as I deleted it the site became responsive . – Adrian Florea Feb 8 at 18:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.