0

I have Synology DS718+, which I am testing with one user (myself) currently.

My transfer rates from my laptop to Synology of around 2 MB/s. However copying FROM Synology back to laptop is around 30 MB/s! - therefore I am ruling network issues out.

Synology is connected directly to a router (1000Mbps) with a cat6 cable. Also in the control panel the interface setting show 1000Mbps, full duplex. Laptop is connecting using WiFi, so I don't expect 1GB, but 2MB is a bit extreme.

My laptop is Ubuntu 18.04, interface set to 1000Mb.

SMB is enabled with SMB2 to SMB3. If I disable SMB Transport Encryption Mode I SOMETIMES get to whooping 3 MB/s

I am about 5m from the router, no walls etc. in the way.

EDIT:

As per Freddy's suggestion (thanks Freddy) I tried different file sizes - always looks similar. However I noticed the speed is increasing very slowly - this can be seen clearly when copying larger file, i.e. 3GB. The file started as always at 2MB and by the end of the copying process transfer rate was ~7.5 MB.

Transfer rates over FTP are exactly the same - very slow copying to Synology and 10-12x faster copying from.

  • Have you tried disabling wifi and connecting the laptop via cable only? Just to rule out that wifi is the bottleneck. What are the transfer rates with cable? – Freddy Feb 11 at 14:10
  • @Freddy I am planning to do it, don't have a cable right now. But note that I mentioned I have 10x better reading transfer rates (text in bold). Therefore it looks to me like SMB configuration issue more than network. – callmebob Feb 11 at 14:21
  • Yes, that's why I said "to rule wifi out". But it would be interesting to see if the transfer rate to the Synology stays at ~2MB/s with cable while the other direction gets (hopefully) a lot faster. Another thing you could test: Is the performance about the same when copying files with different file sizes (1MB, 10MB, 100MB, 1GB)? It sounds like your Synology behaves like a cheap usb3.0 thumb drive -- writes terribly slow, but reads are okay. – Freddy Feb 11 at 14:45
  • Are ftp transfer rates about the same? – Freddy Feb 11 at 14:57
  • Yes, the same. I also noticed another funny behavior. I was copying a bigger file (3GB) and the transfer rate was slowly going up. By the end of the file it got to 7.5MB (started at 2MB as always). – callmebob Feb 11 at 18:34
0

Resolved. It should have been posted on askubuntu, but I didn't know at the time of posting...

Long story short, it was my laptop. I upgraded the kernel from 4.15 generic to 4.20 - that's it. I suspect my WiFi card (Qualcomm Atheros QCA6174) doesn't work well on the factory kernel.

How did I get there:

I started testing with another laptop with W10, which was working very well. So I knew it was not network/SMB config/Synology. So I was trying to set up manual network negotiation mode between my ubuntu laptop and Synology, but I realized my wifi card doesn't give me a lot of configuration options. For example this is what ethtool shows for my card:

$ sudo ethtool wlp2s0
Settings for wlp2s0:
        Link detected: yes

Also dmesg was showing some failures, which unfortunately I don't have to paste anymore.

I started looking for a better driver and ended up installing ukuu and upgrading kernel. Initially I installed 4.20, which worked perfectly, but I had to downgrade to 4.18, because 4.20 has problems with DisplayLink/Evdi, which I use as well. But I confirm that 4.18+ fixes the issue.

Hope this helps somebody.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.