0

I've been trying for several days to find out why the following error is happening to me:

 GET https://www.******.com/ net::ERR_INCOMPLETE_CHUNKED_ENCODING 200 (OK)

I have also looked at some similar questions but nothing has helped me. This error only happens to me in the home page, but in the other URLs of the web everything works as normal.

These are the characteristics of my server:

  • Apache/2.4.18 (Ubuntu)
  • PHP 7.2
  • PHP-FPM
  • App in Symfony 4
  • ISPConfig 3 Panel

UPDATE:

I realized that the problem is in this line FallbackResource /index.php, if I remove it then it works properly, but then the other routes/URL do not work, only the home page, so I do not understand why this happens, and how to fix it.

VHOST Configuration:

<Directory /var/www/******.com>
    AllowOverride None
    Require all denied
</Directory>

<VirtualHost 1.1.1.1:443>

        DocumentRoot /var/www/clients/client0/web1/web/public

        ServerName ******.com
        ServerAlias www.******.com
        ServerAdmin webmaster@******.com
        SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1

         ErrorLog /var/log/apache2/******_error.log
         CustomLog /var/log/apache2/******_access.log combined

        <IfModule mod_ssl.c>
            SSLEngine on
            SSLProtocol All -SSLv2 -SSLv3
            # SSLCipherSuite          ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-RSA-AES256-SHA:ECDHE-ECDSA-DES-CBC3-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA256:AES256-SHA256:AES128-SHA:AES256-SHA:DES-CBC3-SHA:!DSS
            SSLHonorCipherOrder     on
            # <IfModule mod_headers.c>
            # Header always add Strict-Transport-Security "max-age=15768000"
            # </IfModule>
            SSLCertificateFile /var/www/clients/client0/web1/ssl/******.com-le.crt
            SSLCertificateKeyFile /var/www/clients/client0/web1/ssl/******.com-le.key
            SSLCertificateChainFile /var/www/clients/client0/web1/ssl/******.com-le.bundle
            SSLUseStapling on
            SSLStaplingResponderTimeout 5
            SSLStaplingReturnResponderErrors off
        </IfModule>

        <Directory /var/www/clients/client0/web1/web>
            # Clear PHP settings of this website
            Options +FollowSymLinks
            AllowOverride All
            Require all granted
            FallbackResource /index.php
        </Directory>
        <FilesMatch \.php$>
            SetHandler proxy:unix:/var/lib/php7.2-fpm/web1.sock|fcgi://localhost
        </FilesMatch>

        # suexec enabled
        <IfModule mod_suexec.c>
            SuexecUserGroup web1 client0
        </IfModule>


        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
            AssignUserId web1 client0
        </IfModule>

        <IfModule mod_dav_fs.c>
        # Do not execute PHP files in webdav directory
            <Directory /var/www/clients/client0/web1/webdav>
                <ifModule mod_security2.c>
                    SecRuleRemoveById 960015
                    SecRuleRemoveById 960032
                </ifModule>
                <FilesMatch "\.ph(p3?|tml)$">
                    SetHandler None
                </FilesMatch>
            </Directory>
            DavLockDB /var/www/clients/client0/web1/tmp/DavLock
            # DO NOT REMOVE THE COMMENTS!
            # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
            # WEBDAV BEGIN
            # WEBDAV END
        </IfModule>

</VirtualHost>

<IfModule mod_ssl.c>
        SSLStaplingCache shmcb:/var/run/ocsp(128000)
</IfModule>

I hope you can please help me. Thank you very much.

  • 1
    Can you describe what you're doing when you see this error? Can you also tell us wether or not works with a plain HTML (i.e. non-PHP) site or a different PHP application (say a hello-world script). – Andreas Rogge Feb 12 at 21:01
  • Thanks for the help, I tried what you told me, and I realized that the problem is in this line FallbackResource /index.php, if I remove it then it works properly, but then the other routes/URL do not work, only the home page, so I do not understand why this happens, and how to fix it. – jcarlosweb Feb 12 at 21:50
  • And btw... i have been configuring apache httpd for the past 15 years and your configuration is the first time I ever saw FallbackResource. Are you sure this does what you think it does/what you want? – Andreas Rogge Feb 12 at 21:55
  • I'm following the steps here: symfony.com/doc/current/setup/… – jcarlosweb Feb 12 at 22:03
  • The Issue seems to be widespread. See stackoverflow.com/questions/22608564/… – Andreas Rogge Feb 12 at 22:04

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.