0

When I restart my Azure Ubuntu VM and then try to connect to it using Remote Desktop Connection, RDC shows the login screen and after passing the credentials it shows I am successfully logged as shown in the connection log, but the connection is terminated immediately with a message 'Your Remote Desktop Services session has ended.'. The below-attached screenshot shows the same. Error_connecting_to_VM.

After the first attempt to sign in, RDC doesn't show the login screen.

I tried to troubleshoot the issue with the help of following link: https://docs.microsoft.com/en-us/azure/virtual-machines/linux/use-remote-desktop

After I executed the following command sudo netstat -plnt | grep rdp on SSH before the first attempt to login using RDC it worked properly by giving me the output

tcp 0 0 127.0.0.1:3350 0.0.0.0:* LISTEN 53192/xrdp-sesman

tcp 0 0 0.0.0.0:3389 0.0.0.0:* LISTEN 53188/xrdp

But, after the first attempt to login using RDC, it only gives the output

tcp 0 0 127.0.0.1:3350 0.0.0.0:* LISTEN 53192/xrdp-sesman

Please help me with this issue. Thanks in Advance.

  • Maybe the resources of the VM is not enough. You can try to change the VM into a bigger size with more CPU and Memory. Also, you could try to check your network or connect in another place. – Charles Xu - MSFT Feb 13 at 7:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.