-1

This question already has an answer here:

I'm trying to connect to a remote AWS (Ubuntu) server using SSH and keep getting this error msg:

Permission denied (publickey).

On my local machine, under ~/.ssh/config I have this set:

Host someserver
    User potatouser
    HostName serverone.mysite.com
    Port 22

Host dashboard
    User potatouser
    HostName ec2-66-66-66-666.compute666.amazonaws.com
    IdentityFile ~/.ssh/dashboard
    Port 22

Running in the terminal: ssh someserver works fine, asks for a password, and connects me.

Trying to connect to the second server with a private-key.

-rwx------ 1 potatouser potatouser 955 Feb 13 16:49 dashboard

-rwx------ 1 potatouser potatouser 398 Feb 13 17:13 dashboard.pub

On my AWS server, under my user, ~/.ssh/ there is a file named: authorized_keys which has something that looks like a public key inside of it, looks something like this:

ssh-rsa asdasfagdsasfafsafadsfafs..... 
....
...
  • I tried creating a new public file on my server named dashboard.pub (with the same content) in case it's following the file name (?).
  • I tried adding to my config file the setting: IdentitiesOnly yes since I have more than one key files (id_rsa, git repositories keys).
  • I tried editing the files /etc/ssh/ssh_config and /etc/ssh/sshd_config setting PasswordAuthentication to yes ( + sudo service ssh restart).
  • I tried changing the HostName in my config file to an IP instead.

ssh -v dashboard:

OpenSSH_7.5p1 Ubuntu-10ubuntu0.1, OpenSSL 1.0.2g  1 Mar 2016
debug1: Reading configuration data /home/potato/.ssh/config
debug1: /home/potato/.ssh/config line 25: Applying options for dashboard
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: resolving "66.666.666.666" port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to 66.666.666.666 [66.666.666.666] port 22.
debug1: Connection established.
debug1: identity file /home/potato/.ssh/dashboard type 1
debug1: key_load_public: No such file or directory
debug1: identity file /home/potato/.ssh/dashboard-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.5p1 Ubuntu-10ubuntu0.1
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.6p1 Ubuntu-4ubuntu0.2
debug1: match: OpenSSH_7.6p1 Ubuntu-4ubuntu0.2 pat OpenSSH* compat 0x04000000
debug2: fd 3 setting O_NONBLOCK
debug1: Authenticating to 66.666.666.666:22 as 'potato'
debug3: hostkeys_foreach: reading file "/home/potato/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /home/potato/.ssh/known_hosts:25
debug3: load_hostkeys: loaded 1 keys from 66.666.666.666
debug3: order_hostkeyalgs: prefer hostkeyalgs: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521
debug3: send packet: type 20
debug1: SSH2_MSG_KEXINIT sent
debug3: receive packet: type 20
debug1: SSH2_MSG_KEXINIT received
debug2: local client KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1,ext-info-c
debug2: host key algorithms: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,ssh-ed25519,rsa-sha2-512,rsa-sha2-256,ssh-rsa
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,aes192-cbc,aes256-cbc
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,aes192-cbc,aes256-cbc
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com,zlib
debug2: compression stoc: none,zlib@openssh.com,zlib
debug2: languages ctos: 
debug2: languages stoc: 
debug2: first_kex_follows 0 
debug2: reserved 0 
debug2: peer server KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1
debug2: host key algorithms: ssh-rsa,rsa-sha2-512,rsa-sha2-256,ecdsa-sha2-nistp256,ssh-ed25519
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com
debug2: compression stoc: none,zlib@openssh.com
debug2: languages ctos: 
debug2: languages stoc: 
debug2: first_kex_follows 0 
debug2: reserved 0 
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug3: send packet: type 30
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug3: receive packet: type 31
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:asdsadasd
debug3: hostkeys_foreach: reading file "/home/potato/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /home/potato/.ssh/known_hosts:25
debug3: load_hostkeys: loaded 1 keys from 66.666.666.666
debug1: Host '66.666.666.666' is known and matches the ECDSA host key.
debug1: Found key in /home/potato/.ssh/known_hosts:25
debug3: send packet: type 21
debug2: set_newkeys: mode 1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug3: receive packet: type 21
debug1: SSH2_MSG_NEWKEYS received
debug2: set_newkeys: mode 0
debug1: rekey after 134217728 blocks
debug2: key: /home/potato/.ssh/dashboard (0x560d7aa11fd0), explicit
debug3: send packet: type 5
debug3: receive packet: type 7
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug3: receive packet: type 6
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug3: send packet: type 50
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey
debug3: start over, passed a different list publickey
debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/potato/.ssh/dashboard
debug3: send_pubkey_test
debug3: send packet: type 50
debug2: we sent a publickey packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
Permission denied (publickey).

I noticed this:

debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/potatouser/.ssh/dashboard

Could this be becuase it's looking for the dashboard file instead of the dashboard.pub?

marked as duplicate by Gerald Schneider, bodgit, Thomas, Jenny D, cstamas Feb 21 at 22:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Please don't repost your question. Edit your original question if you want to provide more information. – Gerald Schneider Feb 14 at 9:40
  • 2 different errors, shouldn't i open a new question @GeraldSchneider – potatoguy Feb 14 at 9:42
  • Where is this a different error? It is copy&paste from the previous question – Gerald Schneider Feb 14 at 9:44
  • Permission denied (publickey). vs Load key "/home/potatouser/.ssh/dashboard.pub": invalid format after figuring out i have used the wrong key. @GeraldSchneider – potatoguy Feb 14 at 9:45
  • Are you trying to ssh from a remote server to another remote server? try running eval ssh-agent after logging into the first server – Matt Feb 14 at 10:14
0

The public key you are trying to use must be in the target system's authorized_keys -file or it won't be... well, authorized.

Copy your public key's (.pub) content in there, on a new row, and you should have a correct authentication method. If this is the only public key you use, you can just remove the authorized_keys -file and rename (move) the new keyfile as "authorized_keys".

Just copying your public key file "as is" to the target system's .ssh -directory will not be enough.

  • And make sure the private key file has the appropriate permissions. chmod 600 from memory – Matt Feb 14 at 10:43
  • The content of the file authorized_keys already contains the same string of my public key. – potatoguy Feb 14 at 12:11
  • authorized_keys must be chmod'ed 644 on remote host – Archemar Feb 14 at 14:54
0

Permissions for private key should be 400, just in case

Not the answer you're looking for? Browse other questions tagged or ask your own question.