0

I have a network using an M4100 switch connected to an EdgeRouter Infinity. I'm also connecting to the EdgeRouter over PPTP for configuration and testing purposes.

I've created VLAN 80 on the M4100 and tagged the uplink port for VLAN 80. The uplink port goes directly to eth0 on the EdgeRouter and has firewall rules set for providing DHCP/DNS. The services are working perfectly and the M4100 is able to receive an address and resolve forwarded DNS from the EdgeRouter.

The problem I'm having is that when I add VLAN 80 as a sub-interface to eth0 I immediately lose contact with the M4100 until the VLAN is disabled. I've tried applying an IP to the VLAN interface itself (both being the same as the physical interface, another subnet, as well as just leaving the virtual IF subnet undefined) but the result is the same.

  • A tagged VLAN requires that both sides of the link are sending and receiving VLAN tags with the same VLAN ID. Can you change eth0 to use VLAN 80 without tagging? In response to your question, what you might be doing wrong is starting to make configuration changes without having studied and fully understanding how VLANs work. My suggestion is you hit the books/web. – Todd Wilcox Feb 14 at 16:56
  • Some devices just don't support tagged and untagged traffic on the same port; So my first try would be to tag the base port traffic as well - but I don't know the Device you quote, so this is pure debugging. Remember that both devices need to know the VLANs. – dualed Feb 14 at 16:59
  • @ToddWilcox Do you mean setting the M4100 uplink port to untagged? Wouldn't this prevent the traffic headed back to the router from being placed in VLAN 80? Your assessment is a fair one though I often find experimentation in a controlled environment more educational than studying raw data. – SilentOne Feb 14 at 18:00
  • @Dualed If by base port traffic you mean the native VLAN, then yes, I've tried tagging it along with VLAN 80. Then I went to the router and configured a sub-interface for both but I then had a worse problem where I couldn't get to the M4100 management UI and had to switch to another port to undo it. – SilentOne Feb 14 at 18:06
  • Sorry, I should have written "base interface", port was ambiguous, I'd strongly suggest connecting through a different physical interface for management of the edge router, that will make debugging significantly easier, but apart from that it's a bit hard to tell, maybe a more detailed description will help, or maybe it is just device specific behaviour. – dualed Feb 14 at 18:26
0

I've got it sorted out. The first problem I had was that by defining the uplink as a trunk port I was preventing myself from being able to customize the configuration and this is why couldn't untag the trunk port. If you set a port to trunk the Netgear automatically sets the VLANs as tagged for that port. I feel it's actually better to use the VTP section of the switch to define which VLANs are allowed across a trunk port and leave the port itself set to General mode.

Secondly, the trunking problem wasn't entirely a VLAN problem, it was a firewall problem too. I defined a separate set of rules for each virtual interface and am now getting the behavior I expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.