1

Good Evening,

I am a relatively new Linux admin and have set up a file sharing network across our computers at home. I am in the process of moving all things hosted to a box running Centos 7 from a Win10 box which will turn back into a normal workstation. I still want to allow Win10 to put files to the Centos 7 server. So, hello Samba 4.8.3.

As I'm learning Samba and how it works, I've been able to successfully setup and access an anonymous share provided it's on the root drive; however, the instant I attempt to move the directory location from the /samba/anonymous folder to a different drive, I cannot access it from the Windows box.

Here is what my smb.conf file looks like:

============================ Share Definitions ==============================

[anonymous]
comment = Anonymous File Server Share
path = /samba/anonymous
browsable = yes
writeable = yes
guest ok = yes
read only = no
force user = wang

[Movies]
comment = Movies
path = /run/media/wang/Mobile_Wang/Movies
browsable =yes
writable = yes
guest ok = yes
read only = no
force user = wang


[Shows]
comment = Shows
path = /run/media/wang/Big_Wang/Shows
browsable = yes
writable = yes
guest ok = yes
read only = no
force user = wang

I verified the directories and they are good if I access them locally. I also am running a Plex Media server and it can see all the directories. Also, just to be redundant, the Anonymous share is accessible.

I suspect my issue is somewhere in how the drives are mounted, but being a newbie to Linux, I'm a little lost.

Any guidance is appreciated.

  • What do the samba logs tell you? Are there any other relevant logs, e.g. /var/log/messages or /var/log/secure that have any information pertaining to this? – Jenny D Feb 20 at 8:13
1

It's most probably a permission thing.

Please compare ls -ld /samba/anonymous and ls -ld /run/media/wang/Mobile_Wang/Movies. Are group and permissions the same? According to Setting ACLs on the Shared Directories your anonymous folder should have permissions 2775 (rwxrwsr-x) with set group id set.

Even if the permissions are not set as described, then changing "Movies" to the same permissions as "anonymous" should make your movies share accessible. Run chmod -R <perms>/chgrp -R <group> if needed to change permissions recursively.

If your new shares are mounted ntfs partititions, then have a look at How to share NTFS partition with Samba.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.