1

I'm trying to get TightVNC to remote into my Server 2016 instance. I have the VNC Server listening on 5901. I've created a firewall rule in the instance itself, and on my VPC network firewall rules page. Netstat -an doesn't show 5901 as listening. I'm honestly at a loss.

Here's my gcloud compute firewall-rules list response (tight-vnc is the rule I'm working on):

NAME                       NETWORK  DIRECTION  PRIORITY  ALLOW                         DENY  DISABLED
board-login-test-tcp-80    default  INGRESS    1000      tcp:80                              False
default-allow-http         default  INGRESS    1000      tcp:80                              False
default-allow-https        default  INGRESS    1000      tcp:443                             False
default-allow-icmp         default  INGRESS    65534     icmp                                False
default-allow-internal     default  INGRESS    65534     tcp:0-65535,udp:0-65535,icmp        False
default-allow-rdp          default  INGRESS    65534     tcp:3389                            False
default-allow-ssh          default  INGRESS    65534     tcp:22                              False
tcp-5900                   default  INGRESS    1000      tcp:5900                            False
tight-vnc                  default  INGRESS    1000      tcp:5901                            False

And here's the output for gcloud compute firewall-rules describe tight-vnc:

allowed:
- IPProtocol: tcp
  ports:
  - '5901'
creationTimestamp: '2019-02-19T01:27:40.816-08:00'
description: ''
direction: INGRESS
disabled: false
id: '5356307468551353059'
kind: compute#firewall
logConfig:
  enable: false
name: tight-vnc
network: https://www.googleapis.com/compute/v1/projects/tkh-sales-and-service/global/networks/default
priority: 1000
selfLink: https://www.googleapis.com/compute/v1/projects/tkh-sales-and-service/global/firewalls/tight-vnc
sourceRanges:
- 0.0.0.0/0
targetTags:
- instance-1

I don't have a lot of experience so I may be missing something stupid.

1
  • 2
    Netstat -an doesn't show 5901 as listening. that's a problem. Did you run tightvncserver at least once?
    – ALex_hha
    Feb 20 '19 at 9:42
1

It seems that the port isn't serving traffic, I would try to restart the service or confirm that's running correctly, if you are following any guide please let me know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.