0

Is there a way to continue using puppet module generate? I'm using Puppet version 4.10 and earlier I was able to make one without issue, but today when I tried to make one I got the following error:

Error: This action has been replaced by Puppet Development Kit. For more information visit https://puppet.com/docs/pdk/latest/pdk.html.
Error: Try 'puppet help module generate' for usage

I understand that it is deprecated, but we're still using 4.10, so is there a workaround for this?

2

Are you actually running Puppet 4.10? Have you by any chance installed Puppet from a gem that is being found in your $PATH ahead of the system-wide Puppet binary? which puppet and puppet --version will show you where your shell thinks Puppet is and what version it is.

I can still run puppet module generate with Puppet 5.5.x, it displays the deprecation warning but it still works whereas with Puppet 6.x I get the same error as you which makes me think you're running 6.x somehow.

1
  • Ha you're totally right. I accidentally was using the Puppet ruby gem instead of the Puppet application installed on my machine. Fixed the Gemfile to set the Puppet version to 4.10.12 and haven't had an issue since. Thank you! Feb 26 '19 at 22:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.