0

have installed Apache in Redhat following steps given by compile and install Apache link with port 80,

the Apache is working fine without any issue, with proxy settings done with Apache tomcat, but when configuring apache for https using mod_sll i get segement faults as :

apache2417/bin/apachectl: line 79: 13911 Segmentation fault (core dumped) $HTTPD -k $ARGV

 LoadModule ssl_module modules/mod_ssl.so
 # Secure (SSL/TLS) connections
 Include conf/extra/httpd-ssl.conf

and httpd-ssl.conf has an configurations of

 Listen 443

 SSLCipherSuite HIGH:MEDIUM:!MD5:!RC4
 SSLProxyCipherSuite HIGH:MEDIUM:!MD5:!RC4

 ServerName my.domain.com:443
 ServerAdmin my@domain.com

 SSLEngine on

 SSLCertificateFile "location_of_certificate/my_domain_com.crt"

 SSLCertificateKeyFile "location_of_certificate/private.key"

 SSLCertificateChainFile "location_of_certificate/DigiCertCA.crt"

and certificate file are in respective location :

and my logs are :\

    [Mon Feb 18 10:42:18.989494 2019] [mpm_worker:notice] [pid 22284:tid 140198486230912] AH00292: Apache/2.4.17 (Unix) configured -- resuming normal operations
    [Mon Feb 18 10:42:18.989531 2019] [core:notice] [pid 22284:tid 140198486230912] AH00094: Command line: '/webvol/Prod/webdata/webserver/2.4.17/apache2417/bin/httpd'
    [Mon Feb 18 10:43:33.032803 2019] [mpm_worker:notice] [pid 22284:tid 140198486230912] AH00295: caught SIGTERM, shutting down
    [Mon Feb 18 10:43:34.430071 2019] [lbmethod_heartbeat:notice] [pid 22476:tid 140608571279232] AH02282: No slotmem from mod_heartmonitor
    [Mon Feb 18 10:43:34.431362 2019] [mpm_worker:notice] [pid 22476:tid 140608571279232] AH00292: Apache/2.4.17 (Unix) configured -- resuming normal operations
    [Mon Feb 18 10:43:34.431393 2019] [core:notice] [pid 22476:tid 140608571279232] AH00094: Command line: '/webvol/Prod/webdata/webserver/2.4.17/apache2417/bin/httpd'
    [Mon Feb 18 10:50:02.834588 2019] [mpm_worker:notice] [pid 22476:tid 140608571279232] AH00295: caught SIGTERM, shutting down
    [Mon Feb 18 10:50:06.690066 2019] [lbmethod_heartbeat:notice] [pid 23268:tid 140413421766528] AH02282: No slotmem from mod_heartmonitor
    [Mon Feb 18 10:50:06.691799 2019] [mpm_worker:notice] [pid 23268:tid 140413421766528] AH00292: Apache/2.4.17 (Unix) configured -- resuming normal operations
    [Mon Feb 18 10:50:06.691842 2019] [core:notice] [pid 23268:tid 140413421766528] AH00094: Command line: '/webvol/Prod/webdata/webserver/2.4.17/apache2417/bin/httpd'
    [Mon Feb 18 10:55:06.907387 2019] [mpm_worker:notice] [pid 23268:tid 140413421766528] AH00295: caught SIGTERM, shutting down
    [Mon Feb 18 11:06:19.798704 2019] [lbmethod_heartbeat:notice] [pid 25313:tid 139921238067072] AH02282: No slotmem from mod_heartmonitor
    [Mon Feb 18 11:06:19.800453 2019] [mpm_worker:notice] [pid 25313:tid 139921238067072] AH00292: Apache/2.4.17 (Unix) configured -- resuming normal operations
    [Mon Feb 18 11:06:19.800493 2019] [core:notice] [pid 25313:tid 139921238067072] AH00094: Command line: '/webvol/Prod/webdata/webserver/2.4.17/apache2417/bin/httpd'
    [Mon Feb 18 11:06:43.182898 2019] [mpm_worker:notice] [pid 25313:tid 139921238067072] AH00295: caught SIGTERM, shutting down
    [Mon Feb 18 11:06:43.662781 2019] [lbmethod_heartbeat:notice] [pid 25429:tid 140037718632320] AH02282: No slotmem from mod_heartmonitor
    [Mon Feb 18 11:06:43.664166 2019] [mpm_worker:notice] [pid 25429:tid 140037718632320] AH00292: Apache/2.4.17 (Unix) configured -- resuming normal operations
    [Mon Feb 18 11:06:43.664196 2019] [core:notice] [pid 25429:tid 140037718632320] AH00094: Command line: '/webvol/Prod/webdata/webserver/2.4.17/apache2417/bin/httpd'
    [Tue Feb 19 20:27:44.481259 2019] [core:error] [pid 25432:tid 140037366687488] [client 10.224.24.215:40167] AH00135: Invalid method in request TRACK / HTTP/1.1
    [Wed Feb 20 20:00:26.489131 2019] [core:error] [pid 25432:tid 140037417043712] [client 10.224.24.215:54857] AH00135: Invalid method in request TRACK / HTTP/1.1

which says caught sigterm, but by disabling mod_ssl files Apahce seems working fine without https is therr any steo im missing ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.