1

So I am at a loss on this one.

Our TOSHIBA e-STUDIO3005AC printer has been operating perfectly for ~2 years. In the last month, whenever someone scans a document, the pdf will be deposited into our shared drive and all seems well. However some time after that EVERYONE will lose all permissions on the file. This includes SYSTEM, Administrator and everyone below. I cannot even view/change the owner. Sometimes this will happen within 1min of creation sometimes it's the next day, sometimes it never happens at all.

Things tried

  • Resseting ownership on file and parent folder using system and administrator accounts - Access is denied and it fails to enumerate child objects
  • Added Auditing to the parent folder to attempt to track permission changes - Event logs only appear if I manually set permissions on a still working file. Nothing is reported when files 'lock themselves'
  • Tried mounting share in a unix environment to asses permissions and check corrupted files - This was even more baffling as ls lists files that dont exist. For example ls returns DOC190220.pdf but ls -la DOC190220.pdf returns file does not exist. same results using stat DOC190220.pdf
  • Spoke to manufacturers who confirmed printers firmware was up to date and RDC'd in and had a look around. They weren't particularly helpful

Othe notes

  • All other printer functionality is fine
  • We do not use any form of file compression on the drive. Iv'e read a few other posts suggesting this can occasionaly cause issues
  • This is an intermittent problem and the sheer inconsistency is making it extremely difficult to track

Has anyone ever seen anything like this before?

At this point we are about to call in the manufacturers maintenance guru, but I thought I'd post here first as they charge a fortune and I suspect they will tell us to buy a new one. I don't really expect anyone to be able to 'fix' this one for me, but I am curious as to whether anyone has run into something similar, and if so what did you do?

UPDATE A couple of the documents that were previously in-accessible have started working again. As far as I can tell no-one has done anything to change things.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.