I'm trying to use the group policy setting "Interactive logon: Message text for users attempting to log on" but I'm having trouble getting the formatting of the message right; my paragraph breaks (i.e., blank lines) disappear as soon as I press Apply.

I found a suggestion to use ALT-255 (non-breaking space) as an invisible character, which seemed to work at first, but resulted in the message being truncated when displayed on the clients.

I like my blank lines. How can I get them to stay put?


On Windows Server 2016, the following sequence of characters, if placed at the beginning of a paragraph, will display (on Windows 10 clients) as a blank line: quotation mark, space, comma, quotation mark.

In the Security Policy Setting dialog, it looks like this:

First paragraph.
" ,"Second paragraph.

In the Group Policy Management editor, it looks like this:

First paragraph.," ,"Second paragraph.

In the Group Policy Management console, it looks like this:

First paragraph., " ,"Second paragraph.

Unfortunately, every time you edit the group policy object, you will need to recreate the paragraph breaks. My recommendation is to use a separate group policy object just for the logon message, so that you will not break the logon message inadvertently while making an unrelated change.

Another alternative is to directly edit the GptTmpl.inf for the relevant GPO, using any text editor you wish, from the Sysvol share on any Domain Controller. The path looks like this:

\\mycompany.com\Sysvol\mycompany.com\Policies\{GUID}\Machine\Microsoft\Windows NT\SecEdit

Where {GUID} is replaced with the GUID of the GPO, shown in the Details tab of the Group Policy Management Console.

In this case, an end of line is represented by a comma, a blank line looks like this:

First paragraph.," ",Second paragraph.

and embedded commas must be put in quotes.

For completeness, you can also use a startup script to set the logon message although this seems ridiculously rigmarolish to me when there's a perfectly good group policy setting to do it directly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.