0

I do not have internet access from the 172.16.0.0/24 network, I can reach the gateway (192.168.122.1) through the host PC-1 but there is no internet connection.

The IOU1 router is connected to the virtual interface virbr0 which is in NAT mode.

Through the IOU1 router I have normal internet access.

Is there something wrong with my firewall rules?

FILTER TABLE:

Chain FORWARD (policy DROP)
target     prot opt source               destination         
ACCEPT     all  --  anywhere             192.168.122.0/24     ctstate 
RELATED,ESTABLISHED
ACCEPT     all  --  192.168.122.0/24     anywhere            
ACCEPT     all  --  anywhere             anywhere  
ACCEPT     all  --  172.16.0.0/24        anywhere 

NAT TABLE:

Chain POSTROUTING (policy ACCEPT)
target     prot opt source               destination         
MASQUERADE  all  --  172.16.0.0/24       !192.168.122.0/24    
RETURN     all  --  192.168.122.0/24     base-address.mcast.net/24 
RETURN     all  --  192.168.122.0/24     255.255.255.255     
MASQUERADE  tcp  --  192.168.122.0/24    !192.168.122.0/24     masq 
ports: 1024-65535

MASQUERADE  udp  --  192.168.122.0/24    !192.168.122.0/24     masq 
ports: 1024-65535

MASQUERADE  all  --  192.168.122.0/24    !192.168.122.0/24    

An image with a description of the topology: TOPOLOGY

traceroute from the host PC-1:

PC-1> trace 8.8.8.8
trace to 8.8.8.8, 8 hops max, press Ctrl+C to stop
1   172.16.0.1   0.727 ms  0.764 ms  0.579 ms
2   192.168.122.1   0.508 ms  1.015 ms  1.008 ms
3     *  *  *
4     *  *  *
5     *  *  *
6     *  *  *
7     *  *  *
8     *  *  *

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.