1

I'll start by specifying I'm not in the Sysadmin team at work, I work in another building with a small team and we are the "special cases". So they gave me full admin on our servers but I have no knowledge/power on the rest.

I have two servers, let's call them A and B.

A

  • Windows Server 2016
  • 35 TB of hard drives
  • Local network

B

  • Windows Server 2016
  • 200 GB
  • Behind firewalls, loadbalancers and such
  • OpenSSH (Only port 22 is open)
  • Mapped drive to server A on N:

I'm trying to let someone access the files on A by using sftp to server B. I tried symbolic links but it can't locate the folder when using WinSCP. I can't put the files on B since we have about 30 TB of data.

Any ideas? Thank you

  • Is the OpenSSH server running as a service? In what context is the network drive mapped? – eKKiM Mar 1 at 15:00
  • Welcome to ServerFault. Mapping a drive to a letter often gets messy. For example, it might be mapped for an interactive user, but not for a service account. Try referring to the files directory on A via a UNC path instead of a letter drive. That is, as \\A\ShareName\Directory\ , not as N:\Directory. – Doug Deden Mar 1 at 15:20
  • @DougDeden I get an error 4 if I change the symbolic link to the UNC, ssh stops working if I use it on the ChrootDirectory config. – James McGrath Mar 1 at 15:35
  • @eKKiM The OpenSSH is running as local admin... I'll try switching it to the ssh user. – James McGrath Mar 1 at 15:36
1

Thanks to @eKKiM for the hint!

I couldn't run the service as the wanted SSH user, but by using the method used here : https://stackoverflow.com/a/7867064/3549186 I created a task to map the drive as the local System account and for the SSH user.

The symbolic link works perfectly now.

  • Could you flag that as an answer? – Daniel Mar 19 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.