1

After installing Windows Server 2016, I created a Local Administrator Account (say, xyz). I signed in with xyz account. I added Active Directory Domain Services role and promoted server as a Domain Controller successfully. Then, I tried to authorize DHCP. Its failed with error message as follows.

enter image description here

I signed in with Build-in Administrator Account. Then, I tried to authorize DHCP. It’s authorized successfully.

Why DHCP couldn’t get authorized with Local Administrator Account?

Regards

TekQ

1
  • 1
    Is the account a member of Enterprise Admins?
    – Greg Askew
    Mar 2, 2019 at 20:31

1 Answer 1

1

Domain controllers do not have local administrator accounts. Did you restart the server between promoting it to a domain controller and installing DHCP? I suspect not, because that is the only moment where you still have a local Administrator account after DC promotion. And the local Administrator has not the necessary permissions to authorize a DHCP server, which is normal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .