1

Im trying to setup a Windows Server Hyper-V 2012 r2 server which I've installed, but am having issues connecting to it throught the Hyper-V manager on Windows 10. I have followed various instructions about WinRM and CredSSP however I still have the following issue. I launch the hyper-v manager and click 'Connect to server'. I put in the ip address and set the username and password for the hyper-v server. When I click 'Ok' however, I get an error saying 'This computer is not configured to allow delegation of user credentials'. If I click 'Yes' to suposedly allow it to delegate the credentials, the message pops up again. If I click no I get another error saying 'Could not connect to the Virtual Machine Management' and 'A computer policy does not allow the delegations of the user credentials to the target computer'. I can access and control it fine with the Server Manager. Any thoughts?enter image description here

1

Is the Hyper-V server along with Management host joined to the domain? In the case it's not please see the following link - https://social.technet.microsoft.com/Forums/ie/en-US/14c1cb56-c99d-4910-ad17-ec13117e090f/remote-connect-to-hyperv-host-machine-from-windows-10-console?forum=winserverhyperv Where steps with enabling and configuring WinRM described. Alternatively, you can either: 1) disable the firewall 2) configure local group policies as described in link above

| improve this answer | |
  • I'll certainly have a look through this and try some of the suggestions. I'll let you know how it goes! Thanks for your input – TechDomination Channel Mar 6 '19 at 8:25
  • Ok - I've looked through that thread and the tip about using the hostname not the IP address has got me a bit further. When I try and connect, the error about credentials is gone but now I get 'This version of hyper-v manager cannot be used to manage servers running 2012'. I am trying to use a windows server 2016 machine to manage it. Is there an issue there? – TechDomination Channel Mar 6 '19 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.