1

I'm trying to set up an ntp server, and I can't query it. Whenever I try, I get this message:

 6 Mar 18:57:01 ntpdate[27050]: no server suitable for synchronization found

Here is my ntpd.conf file

# For more information about this file, see the man pages
# ntp.conf(5), ntp_acc(5), ntp_auth(5), ntp_clock(5), ntp_misc(5), ntp_mon(5).

driftfile /var/lib/ntp/drift

# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.
restrict default nomodify notrap nopeer noquery

# Permit all access over the loopback interface.  This could
# be tightened as well, but to do so would effect some of
# the administrative functions.
restrict 127.0.0.1
restrict ::1

# Hosts on local network are less restricted.
restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap

# Use public servers from the pool.ntp.org project.
# Please consider joining the pool (http://www.pool.ntp.org/join.html).

server 1.time.nist.gov
server 3.pool.ntp.org

#broadcast 192.168.1.255 autokey        # broadcast server
#broadcastclient                        # broadcast client
#broadcast 224.0.1.1 autokey            # multicast server
#multicastclient 224.0.1.1              # multicast client
#manycastserver 239.255.254.254         # manycast server
#manycastclient 239.255.254.254 autokey # manycast client

# Enable public key cryptography.
#crypto

includefile /etc/ntp/crypto/pw

# Key file containing the keys and key identifiers used when operating
# with symmetric key cryptography.
keys /etc/ntp/keys

# Specify the key identifiers which are trusted.
#trustedkey 4 8 42

# Specify the key identifier to use with the ntpdc utility.
#requestkey 8

# Specify the key identifier to use with the ntpq utility.
#controlkey 8

# Enable writing of statistics records.
#statistics clockstats cryptostats loopstats peerstats

# Disable the monitoring facility to prevent amplification attacks using ntpdc
# monlist command when default restrict does not include the noquery flag. See
# CVE-2013-5211 for more details.
# Note: Monitoring will not be disabled with the limited restriction flag.
disable monitor

////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////// This was my first post, so I don't know how solutions are usually posted, so I'll just put it here. So, it turns out my teacher who's server I was connecting to via ssh had a firewall up that was blocking ntp. He was using firewalld, and to solve this, I used these commands:

firewall-cmd --add-service=ntp --permanent firewall-cmd --reload

Check the status of your ntp server: systemctl status ntpd

If it's down: start the server up: service ntpd start

  • 1
    Connect to the Internet. – Michael Hampton Mar 7 at 4:06
  • That seems a somewhat out-of-date config, but should mostly work. Include the output of ntpq -npc rv and it should show that @MichaelHampton is right and you have no Internet connectivity. – Paul Gear Mar 7 at 9:48
  • Thank you for the help. I am connected on my end. I'm using putty to ssh into my teacher's server and he's in control of everything from that end. I just pinged google to ensure that he's connected, and it worked so I'm not sure what the issue is. – Nate Powe Mar 7 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.