2

I have a test lab deployment and am facing some issue in the first vSAN (4 nodes) creation (it works some times, and other times it doesn't) I'm trying to troubleshooting the issue as to when it doesn't work what is going on.

Once I have added the nodes to the cluster, I add to each node with a VMKernel Adapter and attach the VMKernel adapter to a new switch to which I attach a physical port, then I add vSAN in VMKernel settings, then I attach cache and capacity disks and create a vSAN I can only 100GB SSD in total when I have 100GBx4 SSD.

The issue sometimes this works (not sure if this is due to sequence or what) sometimes it doesn't, of late I have tried it 5 times of which 2 times it worked other times it didnt, this is an All-Flash vSAN.

So I created a new iSCSI vSAN, received an HCL error, fixed it by updating the HCL with json file form vmware.

I receive vmkpings on all interfaces between devices.

Now I can vmkping on all interfaces of but the iSCSI disk still shows only 100GB instead of 400GB in vSAN.

I created a new VMKernel adapter, added it to a new switch, added a new pysical interface to it, added vSAN option to it, however, I am receiving "Host cannot communicate with one or more nodes in the vSAN cluster" for all the nodes.

Anything else I should have done but I didn't.

Thanks all.

2

This issue is resolved.

Since I'm using Workstation and running clones the system UUID is not being generated as new and the same UUID is being used in all ESXi servers (which should not be the case when a clone is created).

So I found the solution here : http://www.vmwarearena.com/vsan-cluster-partition/

I followed as instructed and now I have full 400GB of disks and can access the disk, and create folder in it as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.