0

I have purchased a new Dell Poweredge T330 which has Dell have preinstalled Windows Server 2016 Std onto.

I have a draytek router which is setup for the LAN - it's IP is 192.168.1.1

I have a laptop which has an ip of 192.168.1.18 I have an existing server running on windows 10 machine which has an IP of 192.168.1.10 I have a printer which has an IP of 192.168.1.13

I have plugged my new poweredge into the LAN and the router has allocated it an IP of 192.168.1.19

Despite enabling RDP, I am unable to RDP into the server from my laptop. When I try to ping the server from my laptop I get 'destination host unreachable' error. When I try to ping the poweredge from my old server, I get same error.

When I use the Poweredge to try to ping my laptop I get the same 'destination host unreachable' error. I get the same error when I try to ping the old server at 192.168.1.10. However, when I try to ping the router from the new server (192.168.1.1) it responds. It also responds if I ping www.google.com

Have tried switching off the Windows Firewall on the local network - to no avail.

Can anyone suggest why my server can ping the router, but cannot ping, or be pinged, by any hosts on the same LAN subnet?

Thanks in advance :)

  • I'd start by checking the inbound rules on the Firewall Advanced Settings. Enabling ICMPv4-in might do it – melfors Mar 13 '19 at 16:24
  • Thanks. The Windows Firewall is turned off - but just in case I went to inbound rules and set ICMPv4-In to 'allow'. This has not fixed the issue :( – Matthew Winter Mar 13 '19 at 16:33
0

You are asking for any "suggestion" not the answer, so bear with me. I don't know what might be happening at the OS layer -- windows firewall and the like, but its worth thinking about the network layer.

For client to ping a server,for two hosts on the same (non-routed) network as should be the case here,

  1. client requests the MAC address of the server (and provides its MAC)
  2. server responds with its MAC address
  3. client transmits an ICMP request with the MAC address of the server
  4. server responds with an ICMP reply to the MAC address of the client

For step 1 to work, the client must be able to broadcast at layer 2 -- some switches can be configured to prevent this (private VLAN stuff). The draytek router looks like a SOHO box, so should not prevent this, but its possible.

For step 2 to work, the server must respond with the correct MAC. Its possible, although again unlikely, that the server is responding with the MAC from an incorrect interface.

For step 3 to work, the client must be able to transmit the ICMP request. I'm assuming that your laptop is able to ping things, so that's not likely to be the problem.

For step 4 to work, the server must be able to transmit the ICMP response. You mentioned updating a firewall rule for IP in, but did you adjust IP out? It would be plausible that you would be able to ping your default gate (and correspondingly access other hosts that are routed from that gateway) but be unable to pass traffic to other hosts on the same (non-routed) network.

I would download a copy of Wireshark and see what is going on at the network layer. This would allow you to determine if its a network or OS issue, and shrink the potential problem sources.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.