1

I'm running Zabbix server 4.0.4 on Debian 4.19.12-1. Right now to access my Zabbix server I have an nginx proxy_pass for the front end which is public facing. I can access it with mydomain.com/zabbix.

I don't like that this is public facing, and I'd like to only be able to access zabbix on the local network. IE 192.168.x.x/zabbix. Playing around with the settings, it only allows me to connect to the front end using an nginx proxy_pass which I believe was how it was designed. How do I make the zabbix server only available over the local network so that grafana, which is hosted on the same server, can use it?

/etc/zabbix/zabbix_server.conf

SourceIP=127.0.0.1
ListenPort=10051

/etc/zabbix/zabbix_agentd

Server=127.0.0.1
ListenPort=10050

These are the settings I have. Obviously if I go to 192.168.x.x/zabbix it redirects me to mydomain.com/zabbix. This domain is secured with SSL through nginx, and SSL is enabled on mydomain.com/zabbix.

2
  • Those configuration options refer to the Zabbix server and agent, not the web front end. The server and any agents you may have must be able to access each other, and they are not relevant to configuring access control for the web page. – Michael Hampton Mar 17 '19 at 21:07
  • So that states where the server runs in /etc/zabbix/zabbix_server.conf and where the zabbix_agent listens for the server. How do I disable the front end, and if I do, will the zabbix server be accessible publicly? Also, if the zabbix server is accessed by grafana from mydomain.com/zabbix, how would it be able to connect if I disable the frontend? – CaseJ Mar 17 '19 at 21:12
0

After a little playing around with nginx I just decided to keep the web interface because it seems grafana needs it to be able to work. I just decided to block all IP's and allow only my LAN to access that page with nginx.

allow 192.168.1.0/24;
deny all;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.