0

We have a vCenter Server running in Windows. I am trying to connect to the vCenter server in VMware Workstation 12 via File -> Connect to Server

With the Windows Firewall on, the connection times out and fails. When I turn off the Windows Firewall (domain profile) on the VM which hosts vCenter, the connection is successful. I have opened every port on this list on the Windows firewall, but the connection is still failing (edit - I was mistaken. TCP port 443 was still closed on the "Domain" profile). What is missing here?

EDIT: Can I use Wireshark (or similar) to run a packet-capture while I connect VMware Workstation to the vCSA 6.7 VM? I believe that would show me exactly what is blocked, which would allow me to open the appropriate ports.

  • 4
    "Can I use Wireshark (or similar)" yep that's a good way to do it. Turn the firewall off, open wireshark, run the connection, then filter Wireshark to the vCenter IP address. – Mark Henderson Mar 20 at 22:43
3
+50

VMware Workstation 14.x is able to connect to vCenter using just port 443.

I have verified this with Wireshark including (1) connecting to the server and (2) viewing the remote console.

Your firewall rule may not be applied to the correct network type, and therefore won't work. When you create the exception, make sure you select the type that corresponds to your connection (if in doubt, you can find this in network settings, or by process of elimination - there are only three types):

enter image description here

Note: I realize your question mentions v12.x, however, I thought this answer may also be useful for other users.

  • Thank you, Jens! This resolved my issue on one of the machines with the issue - I still have a machine running Wrkstn 10 that cannot connect, but that must be something else (just a problem with that program or machine). – KidACrimson Mar 21 at 15:41
  • Glad it worked. If the v10 machine connects when the vCenter system's firewall is off, then use Wireshark to get the ports - older products may have used additional ports. – Jens Ehrich Mar 21 at 15:56
  • Thanks again. It actually does not - I'm going to simply upgrade VMware Workstation and see if that fixes it on the older machine (which I think it will). – KidACrimson Mar 21 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.