0

I have to clone and manage some LVM RAW volumes that were created without making filesystem ext4. So I tried to mount this volume and linux didn't find any filesystem to mount. Inside this volumes I have some guest kvm machines. I used to clone virt-clone utility with this syntax:

virt-clone --original vmname --name vmname-clone -f /mnt/pathofcloneddisk/myvmdisk.qcow2

When I tried to boot the cloned machine I get this error:

error: internal error: process exited while connecting to monitor:
(process:31100): GLib-WARNING **:  gmem.c:483: custom memory allocation vtable not supported  
2019-03-19T08:37:21.462102Z qemu-kvm: -drive file=/mnt/pathofcloneddisk/myvmdisk.qcow2,if=none,id=drive-virtio-disk0,format=raw,cache=none,aio=native: 
could not open disk image /mnt/pathofcloneddisk/myvmdisk.qcow2: 
Could not open '/mnt/pathofcloneddisk/myvmdisk.qcow2': Permission denied

My mount point is an nfs share and i have set 777 permission on folder. I would like to ask if is possible to mount or read this qcow2 disk image or start the vm clone because I need to use the clone/mount a backup to try to reset the root lost password. Also is it possible to access to lvm volume that wasn't formatted with a filesystem?

This is my vm xml config file:

<disk type='block' device='disk'>
      <driver name='qemu' type='raw' cache='none' io='native'/>
      <source dev='/dev/mapper/VolumeGroup01-vm001-disk'/>
      <target dev='vda' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
    </disk>

blkid command output:

/dev/mapper/VolumeGroup01-vm001-disk: PTTYPE="dos"

I appreciate so much any suggestion and maybe what is the best practice to cloning and booting kvm guest machines that I haven't access.

  • 1
    Could not open '.../myvmdisk.qcow2': Permission denied - seems like a basic file-system permission issue or caused by the NFS root_squash option – HBruijn Mar 20 at 8:57
  • Thank you @HBruijn for the answer! i find out that nfs permission doesn't allow to boot from nsf share. – micky182 Mar 20 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.