1

I am having issues installing mysqli on our centos 6.1 server after upgrading mysql.

Here is what I get after running yum list installed | grep -i mysql :

mysql.x86_64                        5.1.73-8.el6_8                    @base
mysql-libs.x86_64                   5.1.73-8.el6_8                    @base
mysql-server.x86_64                 5.1.73-8.el6_8                    @base
perl-DBD-MySQL.x86_64               4.013-3.el6                       @base

and here are the results after running yum install php-mysqli

Loaded plugins: fastestmirror, replace, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: centos.mirror.iweb.ca
 * epel: mirror.compevo.com
 * extras: centos.mirror.globo.tech
 * remi-safe: mirror.23media.de
 * updates: centos.mirror.colo-serv.net
 * webtatic: us-east.repo.webtatic.com
Resolving Dependencies
--> Running transaction check
---> Package php-mysql.x86_64 0:5.3.3-49.el6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-49.el6 for package: php-mysql-5.3.3-49.el6.x86_64
--> Finished Dependency Resolution
Error: Package: php-mysql-5.3.3-49.el6.x86_64 (base)
           Requires: php-common(x86-64) = 5.3.3-49.el6
           Installed: php-common-5.4.45-1.el6.remi.x86_64 (@remi)
               php-common(x86-64) = 5.4.45-1.el6.remi
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-49.el6
           Available: php55w-common-5.5.38-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.5.38-1.w6
           Available: php56w-common-5.6.40-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.6.40-1.w6
           Available: php70w-common-7.0.33-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 7.0.33-1.w6
           Available: php71w-common-7.1.26-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 7.1.26-1.w6
           Available: php71w-common-7.1.27-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 7.1.27-1.w6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

It seems like there is a version issue I am running into but I am not the most knowledgable on server issues so I am having a hard time diagnosing it. Thanks in advance for any help.

1

Did you inherit this server? It looks like someone has gone a little crazy with PHP versions and third party repos.

Currently your server is using PHP 5.4 from the remi repository, but you have disabled that repo, and enabled webtatic, from which you don't seem to have anything installed.

Enable the remi repo, disable the webtatic repo, and try again.

To upgrade PHP, make sure the remi-release RPM is installed, then you can choose a different remi repo corresponding to the PHP version you want (e.g remi-php55, remi-php56, etc).

  • This fixed it! I did semi-inherit this server, and after using your tip it looks like there is a lot of cleanup to do. Thanks so much for the help – drumheller Mar 27 at 14:52
  • @drumheller Welcome to Server Fault. If this solved your problem, remember to mark it as solved by clicking on the tick mark so that it turns green. – Michael Hampton Mar 27 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.