1

Migrated a Windows 2008 R2 instance using Cloud Endure to GC. Everything looks great, network rules are set up correctly.

I can remote into the box from behind the firewall and everything is snappy. But when the system is accessed from outside the firewall it's only getting about .5mb of egress speed (RDP/Web). Running speedtest.net locally on the box it's getting 300mb download (bad) and it's only getting .5mb upload, typically this is around 1.4gb.

The network (ip4) settings have no legacy dns settings in them, everything is set to auto. Ipconfig shows no legacy ips attached. netstat -ano shows no activity trying to get to the prior network. Checking network activity via taskmgr shows there isn't any network activity at all.

It's really strange as I did a test run with Cloud endure a few months back without issue.

I even tried spinning up a new box that didn't have 4 extra dedicated IP's configured as this one does and it's the same issue.

Been working on this all day and I'm out of ideas at this point!

Thanks in advance for any ideas! Mike

1

Some instances migrated by Cloud Endure may be configured with a non appropriate MTU and it may cause latency and packet overhead by fragmentation that affects the network performance. [1] Use the following command to check the configured MTU in the Windows instance: $ netsh interface ipv4 show subinterfaces

If the value is higher than the recommended (1430), change it and repeat the tests, as its quite possible that this is related to your issue.


[1] https://cloud.google.com/compute/docs/troubleshooting#packetfragmentation

2
  • Hi Lozano, thanks for the feedback. However that didn't help. They were set to 1500, changed to 1427. Also wouldn't this affect the server regardless of accessing it outside/inside the firewall. The egress is great behind the firewall, it's only outside we have trouble. Either way thanks again! – user3708133 Mar 27 '19 at 17:09
  • 1
    Did you also try to recreate the same instance in GCP from scratch just to verify the connectivity? Are you still having the issue? – Lozano Apr 8 '19 at 5:08
1

It's been noted that windows 2008 and 2012 migrations been facing very slow upload (egress) speed after migration with Cloudendure. For example here and here

This is because of this know issue

There is a fix that works most of the time:

To change your MTU setting in Windows Server 2003 or 2008 use the following steps: Open regedit as an administrator account on the server in question. (Click start , Run then regedit) Navigate to HKLM\System\CurrentControlSet\services\Tcpip\Parameters\Interfaces[Choose the interface in question] (Do this by checking the correct IP address is in the settings under this key for the adapter you are configuring OR the one that has local IP and gate way settings inside it ) Once you are in the correct key for your interface, right-click and select new DWORD value (32 bit). Call it MTU Give this a decimal value equal to 1460 (measured in bytes).

I hope this helps if you have issues with cloud endure.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.