0

I search if my server is running OpenSSL with ALPN support. I need that to know if I have to install OpenSSL again but with ALPN support or I can skip that. I want to build HTTP/2 at DirectAdmin server. I've used openssl version -a | grep -i alpn but nothing showed up.

My system:

CentOS Linux release 7.3.1611 (Core)

OpenSSL:

OpenSSL 1.0.1e-fips 11 Feb 2013
built on: Mon Feb 20 14:38:48 UTC 2017
1

You need OpenSSL 1.0.2 for ALPN support. You would already have this if you had updated your system. You should do that now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.