Initially I had to re-install MySQL when I upgraded to Snow. I managed to get everything backed up to .csv file and was able to migrate to the new install. It worked fine! Earlier this week Mac issued an update to Snow and it seems to have wiped out MySQL again. This time I was unable to run the back-up although all the folders and files are still in place, in the data bin directory.

I had this problem on an iMac and MacBook.

The iMac has all the important data on it (LAN Intranet Server) and I test everything through the MacBook 1st.

I had managed to get the MySQL re-installed and working again on the MacBook and was able to connect the old database so replicated the process on the iMac.

This was unsuccessful. The new install wiped out the old data and still doesn't work.

error includes:

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

Anyway, before I ran the new install on the iMac I managed to drag the data directory onto a USB flash drive as a precaution. I'm hoping once I get the database server running again I can reconnect this data.

Any help at all with any of this problem will be greatly appreciated. Typically this would have to happen the week before the Holiday season and the end of year reports are required by the 'Man with the Plan'.

If any more info is required, I will try to be as clear as I can.


2 Answers 2


Where was your MySQL installed?

And silly questioned, but have you started the MySQL server?


The error only says, that a client could not connect to mysql via socket, for which it looked for in /tmp/mysql.sock. Maybe mysql.sock is located somewhere else, e.g. in /opt/mysql.sock or /Applications/MAMP/tmp/mysql/mysql.sock ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy