0

I have a MySQL 8.0.13 instance running on AWS RDS. AWS documentation says that MySQL 8.0.* does not support IAM DB Authentication. This seems to be true, however my DB somehow has IAM DB authentication enabled.

Image showing IAM db authentication setting

From the web console, there is no option to enable/disable IAM authentication (I assume because AWS recognized this instance is MySQL 8.0.13 thus it does not provide me with that option).

When I try to modify the DB instance from the web console I get this error:

IAM Database Authentication is enabled in the DB Instance but it is not supported for the new configuration from the request. (Service: AmazonRDS; Status Code: 400; Error Code: InvalidParameterCombination; Request ID: b6c909f7-b8db-4a5d-987f-9d715c2e5a6e)

So, IAM DB Authentication is enabled (though it shouldn't be possible on MySQL 8.0.13) and I am trying to turn off Delete Protection, but because IAM DB Authentication is enabled it won't let me change anything in this configuration.

So then I tried from AWS CLI running in an EC2 instance...

aws rds modify-db-instance --db-instance-identifier mydbinstancename --apply-immediately --no-enable-iam-database-authentication

And get the following error:

An error occurred (InvalidParameterCombination) when calling the ModifyDBInstance operation: IAM Database Authentication is enabled in the DB Instance but it is not supported for the new configuration from the request.

I am trying to delete this DB instance so what I thought I would need to do is:

  1. Disable delete protection
  2. Delete DB instance

However, what it seems I need to to is:

  1. Disable IAM DB Authentication (Somehow... This is preventing me from disabling delete protection)
  2. Disable delete protection

  3. Delete DB instance

*Keep in mind I have tried all of this from both the root AWS account and an IAM user account.

0

Did you try disabling the Delete protection without playing with IAM Authentication?

From RDS > Databases 1. Click on the DB Name hyperlink of the database you want to modify. 2. Click the "Modify" button in the upper right. 3. Uncheck the "Enable deletion protection" checkbox at the very bottom of the page and click the "Continue" button. 4. Choose the appropriate scheduling option and click the "Modify DB Instance" button.

Can you try upgrading it by clicking on Modify and change Engine to MySQL 8.0.15 or 16 screenshot to change engine

|improve this answer|||||
  • Yes, when I click Modify DB instance, that is when I get the error: IAM Database Authentication is enabled in the DB Instance but it is not supported for the new configuration from the request. (Service: AmazonRDS; Status Code: 400; Error Code: InvalidParameterCombination; Request ID: b6c909f7-b8db-4a5d-987f-9d715c2e5a6e) – bapin93 Sep 4 '19 at 3:38
  • Did you tried changing the DB engine – PJang Sep 4 '19 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.