1

I have 2 identical PowerEdge R210 servers with RAID1 using SATA SSDs.

In Dell OMSA on the 1st server I see under "Storage > Perc 6/i Adaptor > Connector 0 > Enclosure (backplane)" 2 physical disks named 0:0:0 and 0:0:1.

For some reason on the 2nd identical server the disks names are 0:0 (note missing :0) and 0:0:1. Also the physical disk with the shorter name 0:0 is not under "Enclosure", but directly under "Connector 0". As far as I can tell the mirror is working.

The disks are connected in the same way in both servers in the corresponding drive bays. I don't understand what this means and not sure If I can trust the config should I have a disk failure?

3
  • Have you checked for and installed any available firmware for the server? – music2myear Mar 27 '19 at 22:47
  • Updating the firmware was the answer. I wish I could say it was easy to update the PERC 6/iR controller firmware. Seems the Dell official update is way out of date and I had to install from forums.unraid.net/topic/… to get things working. – cmdln Mar 30 '19 at 14:16
  • If you've solved the problem, please post an answer so that others may know how you solved it. – Michael Hampton Mar 31 '19 at 14:00
1

When seeing differing values or options or other elements in two otherwise identical controllers, the first step of diagnosis and resolution is to check the firmware versions running on the controllers.

Looking for firmware from the OEM is good, but it may be necessary to find the actual manufacturer of the controller to find more up-to-date firmware.

It is not always necessary to install the very latest firmware. However it IS necessary to make sure the same firmware version is running on both controllers in question.

1
  • This is essentially correct, but I couldn't find the firmware for this controller at the manufacturer and had to find it elsewhere. Also the servers were not identical as I thought. The server with the strange naming had newer and larger 2TB SSDs. The latest firmware from Dell did not work correctly, so I installed the latest LSI SAS1068E firmware from elsewhere. – cmdln Apr 4 '19 at 0:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.