2

Have a Windows 2016 ESS R2 server with Mirror RAID 1 on OS & Data Disk, spread over 2 x 2 TBs disks. (Disk 0 & Disk 1). Hardware is a HPE MediaSmart server for home business use. RAID 1 is software Raid, as best I understand it, as configured same solely through Windows 2016.

After a boot failed (Critical Service failed stop code), repaired the OS installation by re-installing W2016 ESS R2 back into OS partition on Disk 0.

All good, so far with Server rebooting and giving me boot option into new (1) R2 OS, or (2) (I guess broken) OS partition on Disk 1.

When I boot into new R2 on Disk 0, and run disk manager, I can see the larger data partition that was windows software mirrored over Disk 0 and Disk 1, but partition is showing "failed redundancy" and I can't access via windows explorer.

I haven't plugged in Disk (1) with the original mirror back into server as yet.

1) Any tips on best way to recover the data partition here?

2) Can I simply re-activate Disk (0) data parition without Disk 1 (mirror) in place. Will a new windows install see the data?

3) Show I add Disk 1 before doing the above?

4) Or is simply importing the Disk 1 into a Windows 10 PC enough to ensure I can see and retrieve data?

Sorry for long winded query here...and ALL help appreciated.

Thanks...JJX

0

Recovering from an SWRAID RAID loss on Windows is a lot harder than Linux. I think you have to edit the bootloader's configuration and whatnot to get up and running. However, you don't have to mess with that.

Simply pop in a new disc. Boot up Linux, and dd the remaining (working) drive, to the new drive. Once Windows boots, everything should "just work". Or at least worked for me. I had a 1 drive loss in a Server 2012 RAID1, and this method, albeit rudimentary, worked fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.