2

To add an extra layer of security I'm using the rootpw option in the sudoers file and while it works perfectly fine from the shell, when a specific command invokes the GUI version of "elevation", only the user password will work in that case and not the root password. Do I need to change anything in PolicyKit config?

Kubuntu 18.10

I'd like the root password to be used everywhere, any ideas?

1

waddayaknow! I found the answer myself: it's indeed to do with policykit. On my Kubuntu 18.10 I had to change the following file (/etc/polkit-1/localauthority.conf.d/51-ubuntu-admin.conf) to have it say:

AdminIdentities=unix-user:root

instead of the default:

AdminIdentities=unix-group:sudo;unix-group:admin

under the [Configuration] section.

Please note that other distro of Linux seem to use a different file for this setting as do other versions of the same distro as well (probably because of the different way that they handle policykit).

You're welcome!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.