0

Installed mongodb on Ubuntu 18.04 LTS, mongod service enabled to start automatically on boot. Configured mongodb.conf to start on 127.0.0.1 and host IP. Could start/stop service with systemctl but failed to start on reboot. If bindIp changed to 0.0.0.0, would work. Unlike most of my machines, this one runs NetworkManager instead of the traditional ifupdown/networking stack.

0

After some experimentation this worked for me:

Changed mongod.service under /lib/systemd/system to use "After=network-online.target" instead of "After=network.target". This results in systemd waiting until networking is completely up before attempting to start mongod (something "network.target" does not require, see https://www.freedesktop.org/wiki/Software/systemd/NetworkTarget/).

0

Can please you try systemctl enable mongod.service and check? this command should enable mongodb at startup, also check /lib/systemd/system/mongod.service file if something handcrafted there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.