1

I have several Samba shares running on my Synology RackStation NAS server. Lets just call these Samba shares:

newton1
newton2
newton3

Each of the newtons is pointing towards a different RAID volume. newton1 and newton3 are working smoothly and accepting files in a timely way, as you would expect a Samba share to. But today I noticed that some users were having difficulty uploading files to newton2 in particular.

On a Windows system; a user copied several files to newton2; the names and file sizes appeared, but these files had no contents.

I tried replicating this on my Linux machine too via Thunar and had similar results.

(Note that this user and I have permissions to write in these files/directories I'm talking about. user=rwx, group=rwx, other=rx)

I tried touch test.txt directly on newton2 and the file appeared, but when I tried editing the contents in Vim I got this error:

"test.txt" E667: Fsync failed

A du . of newton2 shows all of the recently uploaded files are null.

The RAID volume for newton2 shows that only 6GB/30GB are used and the disks all appear healthy.

I'm really stumped at this point... Where do I go from here?

0

same thing is happening on a server of ours, client is a Linux 3.10.0-957.1.3.el7.x86_64 on a CentOS 7 server, mounted through /etc/fstab:

//server/sharedfolder /mnt/mountpoint  cifs    uid=5002,gid=5002,iocharset=utf8,credentials=/home/user/.smbcredentials,sec=ntlm,vers=1.0  0  0

as I am out of idea, I switch the mount to nfs

0

The solution ended up being a Rack Station web interface option that wasn't immediately apparent. The Shared Folder Quota was enabled at a quota size much less than what was already on this disk.

Any incoming data which would exceeded the quota gave a write error because no more data was allowed to be written to that disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.