I get an error after following this guide: https://computingforgeeks.com/how-to-install-ms-sql-on-ubuntu-18-04-lts/ and running the configuration command.

I've searched for a couple hours trying to find the specific issue I have but I can't seem to find anything.

I believe it's something to do with me running Ubuntu 18.10 because installing mssql inside a docker container (as per official M$ guide) does not work either.

The installation itself goes smooth but I get an error at the end of the configuration command and manually starting the mssql service just makes it get a failed status.

Output of the installation command:

The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/178 MB of archives.
After this operation, 927 MB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously unselected package mssql-server.
(Reading database ... 167661 files and directories currently installed.)
Preparing to unpack .../mssql-server_14.0.3076.1-2_amd64.deb ...
Unpacking mssql-server (14.0.3076.1-2) ...
Processing triggers for libc-bin (2.28-0ubuntu1) ...
Setting up mssql-server (14.0.3076.1-2) ...
Processing triggers for man-db (2.8.4-2) ...
Processing triggers for libc-bin (2.28-0ubuntu1) ...

Output of the configuration command:

Enter the SQL Server system administrator password:
Confirm the SQL Server system administrator password:
Configuring SQL Server...

ForceFlush is enabled for this instance.
ForceFlush feature is enabled for log durability.
This program has encountered a fatal error and cannot continue running at Fri Apr  5 15:01:09 2019
The following diagnostic information is available:
       Reason: 0x00000004
      Message: RETAIL ASSERT: Expression=(false) File=Thread.cpp Line=4781 Description=Timed out waiting for thread terminate/suspend/resume.
   Stacktrace: 000000006ad31773 000000006ad2ad0a 000000006ac4b8b1
               000000006ac49dc5 000000006ac02f19 000000006ad6cf48
      Process: 11792 - sqlservr
       Thread: 11904 (application thread 0x1a0)
  Instance Id: 75c7c1b5-ce5f-4436-8acc-a2cdc97b6c0a
     Crash Id: 40695f67-2869-4316-b6e3-786530d7123c
  Build stamp: 70437f6583b8ef39b1ef70539ef84690980315dc7a4436c9c40015f28610e4aa
 Distribution: Ubuntu 18.10
   Processors: 2
 Total Memory: 4136767488 bytes
    Timestamp: Fri Apr  5 15:01:09 2019
Ubuntu 18.10
Capturing core dump and information to /var/opt/mssql/log...
Hint: You are currently not seeing messages from other users and the system.
      Users in groups 'adm', 'systemd-journal' can see all messages.
      Pass -q to turn off this notice.
No journal files were opened due to insufficient permissions.
Hint: You are currently not seeing messages from other users and the system.
      Users in groups 'adm', 'systemd-journal' can see all messages.
      Pass -q to turn off this notice.
No journal files were opened due to insufficient permissions.
/usr/bin/tail: cannot open '/var/log/syslog' for reading: Permission denied
Attempting to capture a dump with paldumper
Captured a dump with paldumper
Core dump and information are being compressed in the background. When
complete, they can be found in the following location:
Initial setup of Microsoft SQL Server failed. Please consult the ERRORLOG
in /var/opt/mssql/log for more information.

The errorlog (relevant bits):

Microsoft SQL Server 2017 (RTM-CU14) (KB4484710) - 14.0.3076.1 (X64)
        Mar 12 2019 19:29:19
        Copyright (C) 2017 Microsoft Corporation
        Express Edition (64-bit) on Linux (Ubuntu 18.10)
2019-04-05 14:58:38.41 Server      Failed to verify the Authenticode signature of 'C:\binn\secforwarder.dll'. Signature verification of SQL Server DLLs will be skipped. Genuine copies of SQL Server are signed. Failure to verify the Authenticode signature might indicate that this is not an authentic release of SQL Server. Install a genuine copy of SQL Server or contact customer support.
2019-04-05 14:58:38.44 spid9s      Polybase feature disabled.
2019-04-05 14:58:38.44 spid9s      Clearing tempdb database.
2019-04-05 14:58:38.52 spid18s     A self-generated certificate was successfully loaded for encryption.
2019-04-05 14:58:39.00 spid9s      Starting up database 'tempdb'.
2019-04-05 14:58:39.23 spid17s     SQL Trace was stopped due to server shutdown. Trace ID = '1'. This is an informational message only; no user action is required.
2019-04-05 14:58:39.24 spid23s     The Service Broker endpoint is in disabled or stopped state.
2019-04-05 14:58:39.24 spid23s     The Database Mirroring endpoint is in disabled or stopped state.
  • Are you definitely running sudo (or as root) on the configuration command? the reason I ask is I see lots of permissions errors including quite basic ones like "/usr/bin/tail: cannot open '/var/log/syslog' for reading: Permission denied" which looks a bit strange...
    – Alex Moore
    Apr 8 '19 at 16:20
  • Yep I run it as sudo. It's weird indeed, fo testing purposes I even chmodded /var/log/syslog to allow full access for everyone and it continued to gave the same error.
    – NullBy7e
    Apr 10 '19 at 5:52


Microsoft's official repository installs version 14.0.3076.1-2 of mssql-server BUT this version is not listed on the cumulative update page and does not seem to install.

The latest version (CU13) which is 14.0.3048.4-1 also failed installing.

I then downloaded the version before CU13 which is 14.0.3045.24-1 and guess what...the installation and configuration went without any problems!

14.0.3076.01-2 FAIL

14.0.3048.04-1 FAIL

14.0.3045.24-1 OK


Are you sure, you meet the minimum requirements as stated here? Because you wrote, it even fails within docker, I assume you maybe have less than 2GB of RAM. mssql will not install if it detects that less than 2 GB of RAM are available.

  • Yes I do. It's a VM with 4GB ram and 2 cores. Good to note that I ran it before, succesfully, but this was a month or two ago - since then I've probably updated/upgraded Ubuntu and now I'm unable to install it. The reason I want to (re)install it is because I noticed that I couldn't reach my mssql server in the first place.
    – NullBy7e
    Apr 10 '19 at 5:52
  • Resolved (see my answer).
    – NullBy7e
    Apr 10 '19 at 6:17
  • Upvoted because it fixed a different problem I had. Thank you.
    – michaelrp
    Mar 5 '20 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.