1

Goodmorning everyone, I hope I will not miss anything in the way of writing this urgent problem of mine and that I have been unable to solve with openvpn for days.

I have a vpn server on raspberry which I can connect perfectly from PCs and smartphones. However from the PC in my office I can't connect correctly. Or rather, I connect, the vpn works (I see the clients in my LAN at home) I see the network resources in the office, ping 8.8.8.8 ok but I don't surf! I thought it was a DNS problem but even putting the google ip address in the browser (216.58.205.195) doesn't solve it.

I would like that when I connect from the office PC only the traffic towards 192.168.1.0/24 passes into the vpn and all the rest passes with the office settings. For this I modified the .ovpn file I have in the office, leaving the "redirect-gateway" option active on the server but adding the DNS of my office:192.168.100.30

Can someone give me a hand? I am in crisis without ideas. Thank you

here my .ovpn file for modifications

client
dev tun
proto udp
remote xxxxx.myddns.net 1194
resolv-retry infinite
nobind
persist-key
persist-tun
key-direction 1
remote-cert-tls server
tls-version-min 1.2
verify-x509-name server_xxxxxxxxxxxxxxxxxx name
cipher AES-256-CBC
auth SHA256
auth-nocache
--pull-filter ignore redirect-gateway
route 192.168.1.0 255.255.255.0
dhcp-option DNS 192.168.100.30
verb 3
0

Can you check your routes in your OS to see where the default route is pointing to? You can also use traceroute or tracert depending on your OS to see where the traffic is going. The configuration looks fine to me. If you're using Windows, you might need to run OpenVPN client as Administrator to work fine.

0

Sometimes automatic MTU discovery does not work properly. Can you check the MTUs used on Office PC side and on the Raspberry? It could be that single small packets get through but larger ones don't. If MTU ist the culprit, maybe MSS clamping could help a little.

I can't comment, so must write this as an answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.