1

This particular environment, it's VMWare guests that have been moved to all-flash SAN, but that shouldn't be particularly relevant.

I'm quite familiar with >winsat formal from SO questions like this one to get Windows to re-test the OS disk. However:

  1. Windows (Server, 2016) only recognizes the change on the OS drive.>winsat disk -drive d (as example) runs the tests, but Defrag/Optimize util still sees all non-OS drives as HDD, and will happily defrag them.

  2. I haven't yet been able to get even winsat diskformal to properly run and "take" over Remote Powershell Sessions. (It appears to run fine via invoke-command, but Defrag will still see it as HDD, unlike running it via RDP session.)

In the meantime, I've disabled the auto-defrag task on all the servers (probably should have been off already.)

So my questions are:

  1. Does anyone know of a method other than winsat to make Windows re-evaluate it's attached drives? (Or a way to make winsat accept/care about the values of non-OS drives.

  2. Has anyone gotten even "winsat formal" to run correctly via invoke-command?

  3. Other than wasting electrons and write-cycles, does Server 2016 do anything differently with disks detected as SSD vs HDD besides allowing defrag, when TRIM is not available. (Being a SAN, it's not.)

4
  • You should be having a chat with your storage admin, and possibly the VMware admin, about this. The SAN could present the volume as thin proivisioned, which Windows would recognize, and then you could re-enable Optimize (as it would just unmap, similarly to local SSD storage). – Michael Hampton Apr 10 '19 at 0:55
  • Interesting @MichaelHampton. I know the actual .VMDKs are thin-provisioned on the backend. (NetApp.) I'm not super-familiar virtual disk thin-provisioning being something the guest os can be aware of. I'll do some research and ask the vm/san folks. – Orangutech Apr 11 '19 at 20:07
  • Ahh, looks like that's using the UNMAP command, which is a (i)SCSI command/primitive. Right, minor detail, these are served over NFS, not iSCSI. (No, I don't know why...) – Orangutech Apr 11 '19 at 20:19
  • Apparently you need NFS 4.2 for this to work. – Michael Hampton Apr 12 '19 at 0:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.