2

During boot, with pre-systemd versions of Ubuntu server (eg. 14.04), if a non-critical fstab disk was offline, the system would wait to mount the disk (30s iirc), timeout and continue booting.

Since upgrading through 16.04 to Ubuntu 18.04, thanks to systemd's dependencies I presume, a missing fstab disk stops the boot process resulting in the "Emergency mode... Press Enter for Maintenance" prompt at boot time.

  1. Is there a way to change this behaviour by default? Ie. simply continue booting or an option to flag disks as non-critical?
  2. Failing that, is there a straightforward systemctl command to 'continue booting ignoring missing disk' from maintenance?
4

In the /etc/fstab entries for your mounts you can add systemd specific options, including the nofail option will instruct systemd that the boot can continue without waiting for the mount unit and regardless whether the mount point can be mounted successfully.

You can add the options x-systemd.device-timeout and or x-systemd.mount-timeout to customize time-outs.

  • Thanks. In the absence of nofail do the x-systemd.*timeout options allow boot to continue without stopping for input on "Emergency mode... Press Enter for Maintenance"? If possible I'd like to wait for a timeout period and continue booting if unsuccessful. – sebt Apr 17 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.