0

Problem: I'm using Debian GNU/Linux 8 and my Logwatch does not have a "Begin httpd" section at all for my Apache pools.

/usr/share/logwatch/default.conf/logfiles/http.conf is set for some custom files:

LogFile = apache2/*.log

Which I believe are being read, since grepping $ logwatch --debug 10, I can see "ADAMANTIUM" and all other custom log files, which are very standard Apache log files.

Logfile Name: http
   001-*applyhttpdate =
   000-*expandrepeats =
   Logfile = /var/log/apache2/ADAMANTIUM.log
   ...
   Preprocessing LogFile: http '/var/log/apache2/ADAMANTIUM.log' 

In /usr/share/logwatch/default.conf/logwatch.conf all the services are enabled:

Service = All
0

Sorry... It looks like it just needed some time: I should not have been testing minutes after starting the new configuration. Which is the whole point of Logwatch: summaries, not real-time logging.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.