0

So I installed MongoDB v4.0 on an Ubuntu 18.10 VM running on Google Compute Engine. Installed successfully, working well with the mongo shell via SSH. Now I wanted to access the database remotely from my desktop.

Following this guide, I edited my /etc/mongod.conf file and commented out the bind_ip line in the following code:

net:

port: 27017

# bindIp: 127.0.0.1

Restarted the service service mongod restart

Also opened the TCP port 27017 on the Google Cloud Platform Firewall.

However, the database is still inaccessible via all means, i.e. the mongo shell installed on my local machine, MongoDB Compass, the server_ip:27017 format on Google Chrome, all fail to connect.

I ran sudo netstat -tlnp via SSH on the VM,

I only got the following line for MongoDB:

tcp 0 0 127.0.0.1:27017 0.0.0.0:* LISTEN 18490/mongod

The 0.0.0.0 line which should have been there indicating that it is open to all connections was still missing.

Can this possibly be a configuration error or is some internal firewall blocking the connection?

Edit: I even made sure iptables isn't causing this. Issued the commands

iptables -A INPUT -p tcp --destination-port 27017 -m state --state NEW,ESTABLISHED -j ACCEPT

iptables -A OUTPUT -p tcp --source-port 27017 -m state --state ESTABLISHED -j ACCEPT

Still no luck

0

Solved it. It was indeed a configuration problem and not a firewall issue.

Apparently MongoDB no longer works fine with bindIp: 0.0.0.0 or commenting out bindIp entirely.

What worked is that I removed the bindIp line and replaced it with

bindIpAll: true

So the final code looks like:

net:

port: 27017

bindIpAll: true

# bindIp: 127.0.0.1

P.S. If you're doing this on your server, don't forget to enable MongoDB authentication

Uncomment the line security: And add authorization: 'enabled' below that.

security:

authorization: 'enabled'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.