I have a RHEL server which by default was running Python2.7 and Python3.4

I needed to use Python3.6 so I downloaded it and built it from source. However, now I seemed to have broken my network connectivity. I can still ssh into the box but none of my HTTPS calls are working which leads me to believe its related to an SSL lib.

After doing research I see that I should have done make altinstall instead of make install

Does anyone know how to reverse this, or where I may look for issues??

  • Sometimes, the make install comand will create a list of the installed files. This list allow the execution of make uninstall, that will remove the installed files. Maybe you'll need to reinstall your distro's python packages, as some files could be overwriten. – JucaPirama Apr 17 '19 at 19:09
  • You can also try to bring your interfaces up manuallly, using ip address or ifconfig for setting the IP and ip route or route for setting the deafult gateway. – JucaPirama Apr 17 '19 at 19:14
  • The network is ok - I can ssh into the box. I just can't make outgoing https connections. I am thinking the SSL lib is broken – Joe Apr 17 '19 at 19:15
  • What are you trying to do (the comand ...)? Are you able to do a nc google.com 443? – JucaPirama Apr 17 '19 at 19:17
  • I am behind a restricted firewall. I can only hit certain sites. I have tried python requests, curl, wget to approved sites. All of which worked before i did this – Joe Apr 17 '19 at 19:18

Try Red Hat Software Collections. The package is rh-python-36. In the rhscl repo and a python3 tutorial on the developer blog, so someone at Red Hat uses it.

Edit: as mentioned in the comments, python36 from EPEL gives you exactly that. So you have at least two choices specifically packaged for RHEL 7.

Installing from source is educational, but time consuming to sort out the dependencies. And reproducible builds are not always easy.

| improve this answer | |

I managed to resolve the issue, but I am still not sure of the root cause. My best guess is that I installed 3.6 incorrectly (did not use altinstall) and I overwrote some critical python2 system links.

To resolve I fully removed Python3.6, fully removed Python3.4, and then removed and reinstalled 2.7. Once 2.7 was re-installed I had my connectivity back.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.