I have set LongPathsEnabled to 1 in Local Group Policy as mentioned here https://superuser.com/questions/1119883/windows-10-enable-ntfs-long-paths-policy-option-missing?answertab=votes#tab-top

Then restarted windows machine. But still get following error

Unable to create output Directory C:\Users\xxxxxxx. Failure Reason 
System.IO.PathTooLongException: The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters.
at System.IO.Directory.InternalCreateDirectory(String fullPath, String path, Object dirSecurityObj, Boolean checkHost)
at System.IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost)
at System.IO.Directory.CreateDirectory(String path)
at Atmel.VsIde.AvrStudio.MakeBuilderService.MakeFileWriter.CreateOutputFolders(IEnumerable`1 subDirectories)

what I am missing here ?

I am on Windows 10 Pro, Version 1803, OS Build 17134.590


You must use a specific instruction in the manifest of your application.

<application xmlns="urn:schemas-microsoft-com:asm.v3">
    <longPathAware xmlns="http://schemas.microsoft.com/SMI/2016/WindowsSettings">true</longPathAware>

If you are not the creator of the application, contact the developer.

You can find more details here: https://blogs.msdn.microsoft.com/jeremykuhne/2016/07/30/net-4-6-2-and-long-paths-on-windows-10/


How are you trying to create the directory? According to a comment in the same thread you linked, it seems that some applications (ie: Windows Explorer) still doesn't support long paths. Also, there's no "1" option in the "Enable Win32 long paths" GPO, only "Enabled" or "Disabled".

What I suggest you to do is enable that GPO, add the Registry value "LongPathsEnabled" as well, and also check the article below to see if you're not using a method that doesn't support long path names, even though it's enabled.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.