0

I create USB with kickstart and it work

On the isolinux.cfg I add:

LABEL Appliance Installation IPAPPEND 2 KERNEL vmlinuz APPEND initrd=initrd.img inst.stage2=hd:LABEL=Appliance7 ks=cdrom:/ks.cfg

But when I try to install it on Intel server type 5500 product S1200RP it hang on

"random: crng init done"

I change the isolinux.cfg ks=cdrom:/ks.cfg to ks=file:/ks.cfg

It is not hang but i get that says anconda missing ks.cfg

when I check the anaconda log is looking for the kickstart on directory /run/install but all the the kickstart is on mounted directory /run/install/repo

So i copy the kickstart to directory /run/install during the installation and it work

How I can fix it that will take the kickstart from /run/install/repo or any else action to make it run

Thanks

1

According to this page: https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/installation_guide/chap-anaconda-boot-options inst.ks (and hopefully its deprecated ks equivalent as well) allows to specify device for the ks file (look at inst.repo details). So you hopefully can use inst.ks=hd:device:/path format and specify device by device name, LABEL= or UUID= and then use this partition's relative path

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.