1

My Linux box is flooded with the following error at a very high rate causing journald to go high CPU which causes CPU fan to get into high gear. Strangely, the network still works. Internet is not much help, only found a few irrelevant articles that's at least several kernels ago. Any ideas on what's going on?

Apr 20 13:18:09 ###.#####.net kernel: alx 0000:08:00.0 eth0: fatal interrupt 0x4019607, resetting Apr 20 13:18:09 ###.#####.net kernel: alx 0000:08:00.0 eth0: fatal interrupt 0x4019607, resetting Apr 20 13:18:09 ###.#####.net kernel: alx 0000:08:00.0 eth0: fatal interrupt 0x4019607, resetting

Here is my box info:

cat /etc/os-release

NAME="openSUSE Leap" VERSION="42.3"

uname -a

Linux ###.######.net 4.4.176-96-default #1 SMP Fri Mar 22 06:23:26 UTC 2019 (a0dd1b8) x86_64 x86_64 x86_64 GNU/Linux

lspci | grep -i ethernet

08:00.0 Ethernet controller: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller (rev 10)

modinfo alx

filename: /lib/modules/4.4.176-96-default/kernel/drivers/net/ethernet/atheros/alx/alx.ko license: GPL description: Qualcomm Atheros(R) AR816x/AR817x PCI-E Ethernet Network Driver author: Qualcomm Corporation, author: Johannes Berg srcversion: 385B6D0DA4526A8E53649AD alias: pci:v00001969d000010A0svsdbcsci* alias: pci:v00001969d000010A1svsdbcsci* alias: pci:v00001969d00001090svsdbcsci* alias: pci:v00001969d0000E0A1svsdbcsci* alias: pci:v00001969d0000E091svsdbcsci* alias: pci:v00001969d00001091svsdbcsci* depends: mdio retpoline: Y intree: Y vermagic: 4.4.176-96-default SMP mod_unload modversions

  • 1
    Your kernel is several kernels ago. Try updating. – Michael Hampton Apr 21 '19 at 21:43
  • Good suggestion. I was hoping to maybe just update the driver. But I will try updating the kernel if I don't hear any other suggestions. – Richard Apr 21 '19 at 22:44
  • AFAIK alx is in tree now, so updating the kernel is updating the driver. – Michael Hampton Apr 21 '19 at 22:48
  • I have updated the kernel. So far these messages are gone. Thanks Michael. – Richard Apr 22 '19 at 5:53
1

Here is a bug report: https://bugzilla.kernel.org/show_bug.cgi?id=102171

It's still not fixed, so upgrading your kernel will not help currently.

Your only option to avoid this is to disable the module.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.