1

I have a late 2009 Imac with Mac OS 10.13.6 High Sierra, installed XAMPP 7.0.30 and trying to run openEMR 5.0.1, I am a really beginner on Server world and PHP too.

At the begining Apache server works well, but after installing open EMR and following the recomendations to run the server properly, the server doesn't work and stops immediately.

The message in the log of XAMPP is below.

Starting Apache Web Server...
Exit code: 8
Stdout:
apache config test fails, aborting
Stderr:

httpd: Syntax error on line 523 of /Applications/XAMPP/xamppfiles/etc/httpd.conf: Syntax error on line 10 of /Applications/XAMPP/xamppfiles/apache2/conf/httpd.conf: /Applications/XAMPP/xamppfiles/apache2/conf/httpd.conf:10: <Directory> was not closed.

These are the lines in boths httpd.conf

Line 523 Include "/Applications/XAMPP/xamppfiles/apache2/conf/httpd.conf"
Line 10 <Directory "/Applications/XAMPP/xamppfiles/htdocs/openemr"

http.conf below

Alias /bitnami/ "/Applications/XAMPP/xamppfiles/apache2/htdocs/"
Alias /bitnami "/Applications/XAMPP/xamppfiles/apache2/htdocs"

<Directory "/Applications/XAMPP/xamppfiles/apache2/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>
<Directory "/Applications/XAMPP/xamppfiles/htdocs/openemr">
      AllowOverride FileInfo
  </Directory>
  <Directory "/Applications/XAMPP/xamppfiles/htdocs/openemr/sites">
      AllowOverride None
  </Directory>
  <Directory "/Applications/XAMPP/xamppfiles/htdocs/openemr/sites/*/documents">
      order deny,allow
      Deny from all
  </Directory>
  <Directory "/Applications/XAMPP/xamppfiles/htdocs/openemr/sites/*/edi">
      order deny,allow
      Deny from all
  </Directory>
  <Directory "/Applications/XAMPP/xamppfiles/htdocs/openemr/sites/*/era">
      order deny,allow
      Deny from all
  </Directory>

other httpd.conf

Line 523 Include "/Applications/XAMPP/xamppfiles/apache2/conf/httpd.conf"

What do I have to do be able to run apache again?

1

The error message says it all: <Directory> was not closed. You only have <Directory ...

Add ">" to the end of line 10 so that the line reads:

<Directory "/Applications/XAMPP/xamppfiles/htdocs/openemr">
  • Hello Wurtel Thanj you for your help, I posted another answer with the code in httpd.conf – Chema Moriñigo Apr 23 at 11:29
  • I did all how you tell me and server shows the same alert and doesn't star – Chema Moriñigo Apr 23 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.