1

We have set up a new infrastructure and all our Laptops/PCs have a the same error: When trying to open a website from a local webserver, it takes between 10 and 30 seconds. During this time it does not even start to load the site.

Setup

  • Lenovo T Series Notebooks (might be relevant since Lenovo has its own security software)
  • Windows 10
  • All notebooks are administered via Microsoft Azure AD with standard settings

Things we've tried so far

  • It doesn't matter if the server gets called via 127.0.0.1 or localhost.
  • It also does not matter which port it is.
  • We have deactivated Antivirus, Firewall and Smartscreen. No success.
  • It occurs with every website content and webserver (we have tried Apache, Node apps and others). Even with a simple line of code.

Analysis

  • Ping on localhost and 127.0.0.1 is successful with < 1ms
  • etc/hosts file has no entries
  • Netstat is showing the following. For instance, if we are using the standard port 80, it has several entries:
  • 127.0.0.1:80 - 0.0.0.0:0 - Listening
  • 127.0.0.1:80 - 127.0.0.1:50503 - Established
  • 127.0.0.1:50503 - 127.0.0.1:80 - Established
  • Looks like a loop. Is there something wrong?

What we suspect

  • It might be routing issue
  • It might be a security issue (we deactivated a lot of things as described above, but there might be something else?)

Ideas and and any help is appreciated. Thank you very much.

  • Can you try to capture the problem with Wireshark and see if you can find some interesting delays or errors ? About the Netstat's output, it looks good to me: 1st line: webserver listening. 2nd and 3rd line: connection between the server and the client (himself in this case). Additionally, can you tell us if the server is connected to Internet and if you are using https to access the localhost/127.0.0.1 website ? – Swisstone Apr 30 at 18:19
  • Please don't edit your solution into your question. Instead, post an answer and accept it. Otherwise the question will stay as "unanswered" in the system and pop up again and again in the future. – Gerald Schneider May 16 at 13:07
  • Thank you. Will do. – Sven OS May 20 at 19:19
0

Problem got solved

Our laptops got an Windows Update approximately a week after and the problem was randomly solved for everyone. Windows Updates were activated from the beginning so I'm really not sure what has caused the error and what solved it.

Maybe there were some dependencies in the updates and they got slowly rolled out and one of the last updates fixed the system.

This answer might not be satisfying but it is gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.