2

I am on CentOS 7. When I do a yum update, it shows me this issue:

** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
php-7.3.4-1.el7.remi.x86_64 has missing requires of httpd-mmn = ('0', '20120211x8664', None)

There's no httpd or Apache on my server. The repos I have include:

# yum repolist 
Loaded plugins: fastestmirror, replace
Loading mirror speeds from cached hostfile
 * base: mirror.cc.columbia.edu
 * epel: epel.mirror.constant.com
 * extras: mirror.cc.columbia.edu
 * remi-php72: mirror.team-cymru.com
 * remi-php73: mirror.team-cymru.com
 * remi-safe: mirror.team-cymru.com
 * updates: mirror.cc.columbia.edu
repo id                                      repo name                                                                        status
base/7/x86_64                                CentOS-7 - Base                                                                  10,019
epel/x86_64                                  Extra Packages for Enterprise Linux 7 - x86_64                                   13,125
extras/7/x86_64                              CentOS-7 - Extras                                                                   387
mariadb                                      MariaDB                                                                              67
nginx/x86_64                                 nginx repo                                                                          150
remi-php72                                   Remi's PHP 7.2 RPM repository for Enterprise Linux 7 - x86_64                       367
remi-php73                                   Remi's PHP 7.3 RPM repository for Enterprise Linux 7 - x86_64                       307
remi-safe                                    Safe Remi's RPM repository for Enterprise Linux 7 - x86_64                        3,188
robert-gcj/x86_64                            Copr repo for gcj owned by robert                                                    16
robert-pdftk/x86_64                          Copr repo for pdftk owned by robert                                                   3
updates/7/x86_64                             CentOS-7 - Updates                                                                1,840
repolist: 29,475

What do I need to do to remove that error during yum update?

3

You can remove the package. The package named php is only for Apache installations and is not used for nginx/php-fpm. That package is named php-fpm and it is the one you should have installed.

yum remove php

If you don't already have php-fpm installed, execute this command instead:

yum swap php php-fpm
1
  • Thank you Michael. This works!
    – Khom Nazid
    May 2 '19 at 4:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.