0

So, I was trying to learn how to use GAE, so I used an app template from Github to make a test app.

That worked fine, but now when I want to start working on my real app...

I get this error after running gcloud app deploy:

ERROR: (gcloud.app.deploy) Service [default] uses unsupported Python 2.5 runtime. Please use [runtime: python27] instead.

The earlier app must have used Python 27, but I want to use Python 3.

However, I cannot find a way to change the runtime for the default service.

Is there any way to do this, and if not, what should I do about it?

1

To run Python3 app, use the following in your app.yaml file:

runtime: python37

More info on running Python 3 on App Engine Standard is here: https://cloud.google.com/appengine/docs/standard/python3/runtime

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.