2

I am trying to update the iLO 4 firmware on a HP ProLiant DL360p Gen8. It's a VMHost, running VMware ESXi, 5.1.0, 2323236. The VM's it runs are Windows Server 2008 R2 Standard.

It's currently running iLO Firmware v1.5.1. I am trying to update it to 2.61, same as our other servers. I have done this update many times through the iLO Web Interface, by uploading the ilo4_261.bin file, etc. This is the first and only server I've had this issue on across many generations and models of HPe servers.

For some reason, this particular server fails to update. It gets stuck on the screen of "Checking HP Secure Digital Signature", and at the bottom of the screen, indicates "Firmware Flash Progress: 1 %" - below is screenshot of this. It will stay this way indefinitely (weeks at least) until the server is disconnected from power. There's no option to cancel it, or try it again, etc.

I have tried many things to resolve this, here is a list:

  • Tried restarting ("resetting") the iLO itself from the Diagnostics page, as well as from hponcfg. While the iLO does seem to restart, it goes right back to this stuck updating status upon login.
  • This error / failure to update I'm seeing, is actually mentioned in the HP iLO 4 user guide. It says the resolution is to reset the iLO to defaults using hponcfg -r. I have done this from the /var/hp/tools/ install on ESXi on the server, and while it did successfully reset settings to defaults (set IP to 0.0.0.0, wiped user accounts etc), the iLO still is stuck in updating status afterwards.
  • I used an hponcfg script to update the iLO firmware from the command line. This fails with the following error. I can see this error in the RIBCL guide, and the error guide, but there is no explanation of what this error actually means or how to resolve it! I am assuming that this error is just saying it's failing to flash, due to it being stuck in this state? Here's the error in the full output:
/opt/hp/tools # ./hponcfg -f firmware.xml
HP Lights-Out Online Configuration utility

Version 4.4-0 (c) Hewlett-Packard Company, 2014
Firmware Revision = 1.51 Device type = iLO 4 Driver name = hpilo
iLO IP Address: 0.0.0.0
</-- ERROR :      STATUS= 0x005E
     MESSAGE= Open flash part failed. -->
Script failed
/opt/hp/tools #
  • I contacted HP support in this thread. They recommended that I disconnect the server from power to get the iLO out of this stuck updating state; and then upgrade the firmware to 2.10 instead, as an intermediate update.
    • While power draining the server did get it out of this stuck updating state - the very next time I tried to update it to 2.10, it went back to this stuck updating state, where it is still stuck as of today.

As this is a high availability host that is typically only remotely managed, I really want to limit the number of times I have to ask our customer to go on site to unplug this from power again.

My current thought is to have them power drain it again, wipe settings to default, then try and flash the firmware from the command line using hponcfg and see if it goes through in that state? But I don't have a lot of faith that it will work; so I'm hoping someone has a better suggestion, or knows of a different way to get the iLO out of this state - or knows if perhaps this will require the server motherboard to be replaced?

Thank you in advance for any suggestions!

Here's a screencap of how it's stuck in the WebUI of the iLO: enter image description here

  • 1
    What operating system is in use here? – ewwhite May 2 at 15:29
  • The server is a VMhost, running VMware ESXi, 5.1.0, 2323236. The VM's it runs are Windows Server 2008 R2 Standard. – Protonus May 2 at 16:07
2

Upgrade your system and ILO firmware out-of-band by using:

Or...

Upgrade the ILO firmware using the purpose-built packages for your version of VMware ESXi. The instructions are at the link.

  • Can any of these be done while the iLO is stuck in this "Updating" state? Or will the server need to be power drained again before attempting these? – Protonus May 2 at 16:12
  • The first two are done in the BIOS or by booting another OS. I didn't realize you had such an old version of VMware. There's an installer for it, but I don't have time to dig for the specific URL. – ewwhite May 2 at 16:25
  • I just tried to use the the last method, using the steps for "To update firmware from VMware ESXi operating system on target server:". Unfortunately it also got an error, posting in next comment. I'm guessing I'll need to have them power drain the server again first before trying this again? – Protonus May 2 at 16:34
  • ./CP038289.vmexe iLO Flasher v1.0.5-1 for VMware ESXi (C) Copyright 2002-2016 Hewlett Packard Enterprise Development LP Firmware image: ./ilo4_262.bin Current iLO 4 firmware version 1.51; Serial number ILOUSE230A825 Component XML file: ./CP038289.xml ./CP038289.xml reports firmware version 2.62 This operation will update the firmware on the iLO 4 in this server with version 2.62. Continue (y/N)?Y Current firmware is 1.51 (Jun 16 2014 00:00:00) Firmware image is 0x1001b1c(16784156) bytes Failed(2-3)! ERROR: Unable to start flash. [./ilo4_262.bin] /tmp/ilo # – Protonus May 2 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.