0

I have a server which is used purely for outbound email. I would like opendkim to sign every email going through, assuming it has a signing table entry. However, I can't seem to find any documentation for the correct MTA value I need, or any instructions on how to find it (I'm using Postfix).

Originally I had it set to the hostname, but I'm getting messages like the following in the log, which I find confusing as it shows no match, but lists matching values.

no MTA name match (host=my.full.hostname, MTA=my.full.hostname)

At the moment I have the MTA setting commented out, but it is currently only signing emails from authenticated users. I ideally need it to sign anything coming from an allowed relay source - without having to duplicate every single relay into the trusted/internal list.

0

If anyone has a similar issue it seems to be working if I configure opendkim to use a file for the MTA name rather than providing it directly as a string. (According to the documentation either should be equivalent)

MTA file:/path/to/mta-list.txt

mta-list.txt:

my.full.hostname

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.