I'm connecting to a Debian 5 server using PuTTY on Windows 7 from home. I have ADSL internet connection and a D-Link ADSL modem.

I've got a strange problem since 2 days ago. SSH connections became extremely slow, sometimes PuTTY fails to connect and sometimes it just hangs then times out in the middle of a session. My internet connection seems to be fine since my bandwidth is stable, i have no packet loss to anywhere including the server I'm talking about and there is no latency. Everything works just fine except for SSH.

I thought it might be something wrong with PuTTY so i tried 2 other SSH clients but i got the same strange slowness effect. I don't have access to any other server to see if SSH has the same problem or not. My friend connects to the mentioned server from somewhere else but he doesn't have this problem so i assume the server is not the cause.

I haven't tried to use another computer inside my home's NAT to see if it has the same problem or not. It makes no sense to me since everything was fine before 2 days ago. Could it be caused by the ISP?

Does anyone have an idea about how to fix the problem or how to find the cause?


  • Run wireshark on your side and tcpdump on server side, look at timestamps and/or lost packets (I know you said you don't have it, but there are cases where you'd see let's say 100% ping replies, but lost packets of other kinds). – Max Alginin Dec 22 '09 at 6:12
  • is the debian server and your windows computer on the same LAN? – SiegeX Dec 22 '09 at 6:37
  • No the server is a dedicated server located in another country. I'm connecting to it using Internet – redclover Dec 22 '09 at 7:18
  • Did your friend using the same Putty and Win version ? Try another ssh client. Try FileZilla ssh connection, any problem to send a file to your server ? – PeterMmm Dec 22 '09 at 8:06
  • @PeterMmm Yes, my friend is using PuTTY on windows 7 but he uses another ISP. Sending files sometimes works and sometimes not, but when it works its SO slow and may get terminated. – redclover Dec 22 '09 at 9:44

Which ISP are you using? That info might be useful as other people on the same ISP may be able to confirm the behaviour (as they have the same problem) or report all is well for them (indicating that the ISP doesn't have a general problem with SSH traffic).

One possibility if it is the ISP, is that they've changed their traffic management structure and it is mistaking your encrypted SSH connection as an encrypted P2P connection. If you can turn off the web server at the other end temporarily without causing to much trouble, try running SSH on port 80 to see if it runs better that way (if it does then something somewhere is probably doing port based traffic shaping that is affecting SSH). You could also try a bulk transfer via SSH (i.e. a download via SCP/SFTP) running through a HTTP based tunnel like this one to see what difference it makes (it will need to be a bulk transfer, as otherwise any performance issues will be hidden by the extra latency added by the tunnel).

  • When i tunnel the SSH connection through HTTP everything works just fine. It seems that my ISP is the cause after all. – redclover Jan 8 '10 at 10:44

Have you checked for IPv6 problems?

Windows 7 tries IPv6 by default AFAIK. Does the server have an AAAA DNS record?

Maybe you friend with the other ISP has working IPv6 or no IPv6.


It's likely to be related to slow DNS resolving. Check the DNS settings in windows and on your router.

Often its best to set up statically the DNS servers on your windows machine to the DNS address provided by your ISP as many home routers have very poor/slow resolvers. Setting them statically does away with the DNS forwarder in the router.

Sorry, this would only be worth trying if you had a slow connect. You're saying that it often times out in the middle. Look at the server logs and see if anything shows up there.

It could be any number of things, if nothing showing in server log, checking by using ssh or putty from another location. e.g. a friends house. If it's fine there then your issue is either with your ISP or more likely with something in your network, either your machine or your router. Try another pc on your local network if you have a laptop you can borrow or even another router. Also, disable windows firewall temporarily or antivirus temporily and see if the problems persist.

  • I've looked my router settings. Its Main and second DNS addresses are automatically set to my ISP's DNS servers. Do you suggest changing them to something else? – redclover Dec 22 '09 at 6:18
  • You can try using and as your two DNS servers. These belong to Google's new public DNS service. – SiegeX Dec 22 '09 at 6:39
  • 2
    "sometimes it just hangs then times out in the middle of a session" -- that's not going to be caused by DNS. – womble Dec 22 '09 at 6:54
  • err, read slow connect. – hookenz Dec 22 '09 at 6:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.