2

I am seeing the errors below while installing perl-moose using command yum install perl-Moose

Can someone please help me with commands on how to install these dependencies? Thanks in advance

Error: Package: perl-Moose-2.1005-1.el7.x86_64 (epel)
           Requires: perl(Dist::CheckConflicts) >= 0.02
Error: Package: perl-Eval-Closure-0.08-4.el7.noarch (epel)
           Requires: perl(Sub::Exporter)
Error: Package: perl-Sub-Exporter-Progressive-0.001011-1.el7.noarch (epel)
           Requires: perl(Sub::Exporter)
Error: Package: perl-Moose-2.1005-1.el7.x86_64 (epel)
           Requires: perl(Sub::Exporter)
Error: Package: perl-Moose-2.1005-1.el7.x86_64 (epel)
           Requires: perl(Sub::Exporter) >= 0.980
Error: Package: perl-Devel-PartialDump-0.15-8.el7.noarch (epel)
           Requires: perl(Sub::Exporter)

My linux and Perl version is as below

NAME="Red Hat Enterprise Linux Server"
VERSION="7.6 (Maipo)"

This is perl 5, version 16, subversion 3 (v5.16.3) built for x86_64-linux

2
  • Have you enabled epel on the machine? – choroba May 3 '19 at 15:25
  • @choroba yes epel is enabled. I removed perl and reinstalled in using yum --enablerepo=epel install perl . I still have the same error. The installed version is still v5.16.3 – Santosh Pillai May 3 '19 at 15:31
3

The missing packages are in the RHEL optional channel, which you need to enable first.

subscription-manager repos --enable=rhel-7-server-optional-rpms

When using RHEL on AWS, enable it this way instead:

yum-config-manager --enable rhui-REGION-rhel-server-optional
1
  • Wow, thats amazing. I spent the whole day trying to get this working. Thanks for the AWS way to enable this (this is exactly what I needed) – Santosh Pillai May 3 '19 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.